Check out the LimeSurvey source code on GitHub!

Loosing email formatting

More
6 years 4 weeks ago - 6 years 4 weeks ago #55644 by waitz
Hi C

Thanks. I attach the same survey twice:
-The csv file is the original survey with formatting of the welcome message intact
-The lss file is the same survey after I opened the welcome message for the survey and saved it again.

I PM you the password for the zip file.

File Attachment:

File Name: survey.zip
File Size:30 KB

Version 1.91+ Build 11232 | PHP 5.3.9 | MySQL 5.1.56 |
Attachments:
Last Edit: 6 years 4 weeks ago by waitz.

Please Log in to join the conversation.

More
6 years 4 weeks ago #55648 by waitz
I did a test: I copied all the limesurvey files to a local wamp server, ran the installation script, and opened limesurvey admin there. Everything is ok.

So I deleted the db on our webserver, and ran the installation script again, but I get the same errors as before. So it must be something on the webserver that causes it, right? But what.....?

Version 1.91+ Build 11232 | PHP 5.3.9 | MySQL 5.1.56 |

Please Log in to join the conversation.

More
6 years 4 weeks ago - 6 years 4 weeks ago #55653 by c_schmitz
IMporting and saving the welcome text works just fine here - so it really is something with your hosting. I guess some server-side filter is removing the HTML - but is is just a guess. Never have seen something like this before.

You should use another hosting or use LimeService to create online surveys : www.LimeService.com

Best regards

Carsten Schmitz
LimeSurvey project leader
Last Edit: 6 years 4 weeks ago by c_schmitz.

Please Log in to join the conversation.

More
6 years 4 weeks ago #55658 by waitz
Thanks, I will contact the host. We have a tuned up host for Joomla, so I will try to find a solution before I change the host.

Version 1.91+ Build 11232 | PHP 5.3.9 | MySQL 5.1.56 |

Please Log in to join the conversation.

More
6 years 4 weeks ago #55659 by Mazi
Once you have solved this issue please report back so that other users will benefit from your solution, too.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
6 years 4 weeks ago #55667 by waitz

Mazi wrote: Once you have solved this issue please report back so that other users will benefit from your solution, too.

Of course. Checked with the host, and they say that nothing on server side would strip out HTML...

Version 1.91+ Build 11232 | PHP 5.3.9 | MySQL 5.1.56 |

Please Log in to join the conversation.

More
6 years 4 weeks ago - 6 years 4 weeks ago #55719 by waitz
I temporarily installed it on a different web host, and it works just like it is supposed to, so there is definitely something with the current server. I have asked in the Joomla forum if joomla can be the one creating a conflict, but no one has answered yet.

Is there anything else I can check with our host, or something else I can check..? I would like to keep it on the current host, because I have private ssl and a high mysql security solutions there...

Version 1.91+ Build 11232 | PHP 5.3.9 | MySQL 5.1.56 |
Last Edit: 6 years 4 weeks ago by waitz.

Please Log in to join the conversation.

More
6 years 4 weeks ago #55729 by waitz
I FOUND IT!!! It was the security application that stripped the html, preventing XSS attack :blush:

It is solved, which I am very happy about. Thanks for all input. :silly:

Version 1.91+ Build 11232 | PHP 5.3.9 | MySQL 5.1.56 |

Please Log in to join the conversation.

More
6 years 3 weeks ago #55771 by Mazi

waitz wrote: I FOUND IT!!! It was the security application that stripped the html, preventing XSS attack :blush:

It is solved, which I am very happy about. Thanks for all input. :silly:

What kind of "security application" do you mean?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
6 years 3 weeks ago #55774 by waitz
I have a stand-alone security application on the webserver that monitors all folders, files and mysql. And I just had to make an exeption for limesurvey

Version 1.91+ Build 11232 | PHP 5.3.9 | MySQL 5.1.56 |

Please Log in to join the conversation.

More
6 years 3 weeks ago #55856 by Mazi
I see. I thought it was a certain PHP module like suhosin or mod_security, these often cause problems.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
6 years 3 weeks ago #56158 by waitz
Currently I have disabled the XSS Filter security for the whole limesurvey directory, so that I don't have problems with the above. But I think this is actually not necessary.

I need to disable it only for the part where I edit the surveys in the backend, both questions and welcome/end settings, and the part that sends out emails.

If I would limit the XSS disabling in our security application for just the directories that handles the above, which directories (or files?) would that be..?

Version 1.91+ Build 11232 | PHP 5.3.9 | MySQL 5.1.56 |

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form