Check out the LimeSurvey source code on GitHub!

Problem export to QueXml

More
6 years 5 days ago #55174 by heso
Hi!
I have some problem when i try to export to Quexml
this happens:
Warning: Call-time pass-by-reference has been deprecated; If you would like to pass it by reference, modify the declaration of create_subQuestions(). If you would like to enable call-time pass-by-reference, you can set allow_call_time_pass_reference to true in your INI file in C:\wamp\www\limesurvey\admin\export_structure_quexml.php on line 387


Warning: Cannot modify header information - headers already sent by (output started at C:\wamp\www\limesurvey\admin\export_structure_quexml.php:466) in C:\wamp\www\limesurvey\admin\export_structure_quexml.php on line 520


What should i do?
I tryed to change to allow_call_time_pass_reference = On but still the same problem

Regards Tony

Please Log in to join the conversation.

More
6 years 4 days ago #55208 by Mazi
1. Which Limesurvey version do you use?

2. Which PHP version dou you use?


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
6 years 4 days ago #55211 by heso
tryedboth 1.90 and the newest same problem, i use newest php on wampserver

Please Log in to join the conversation.

More
6 years 4 days ago #55225 by Mazi
What does "newest PHP" mean? Is it 5.3 or a newer, maybe not yet stable version?

You can test if this is fixed at the latest version by testing our online demo at demo.limesurvey.org/admin (external link) which always runs the latest Limesurvey version.
Username: admin
Password: test
If you can reproduce the problem there please get back in touch.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

More
6 years 3 days ago #55271 by adamzammit
This is a bug. This warning will only appear on PHP >= 5.3.0.

I have fixed this in revision 9703.

Please Log in to join the conversation.

More
6 years 3 days ago #55272 by heso
where do i find the solution?

Please Log in to join the conversation.

More
6 years 3 days ago #55273 by adamzammit
It will appear in the next release candidate or final version of 1.9.1

Otherwise, you can replace the file:

admin/export_structure_quexml.php

In your Limesurvey 1.9.1 RC 2 installation with the following:

limesurvey.svn.sourceforge.net/viewvc/li...=markup&pathrev=9703

Please Log in to join the conversation.

More
6 years 3 days ago #55274 by heso
worked!! thank you

Please Log in to join the conversation.

More
6 years 3 days ago #55294 by Mazi
You're welcome!

If our hints have been helpful and you enjoy limesurvey please consider a donation to the team .
We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com'"

Please Log in to join the conversation.

Imprint                   Privacy policy         General Terms & Conditions         Revocation information and revocation form