Panel integration -end link

More
9 months 3 weeks ago #174512 by ipazur
So, I read all the instructions, all topics but I am still helpless... I am not an expert and always some step is missing... after some long hours I managed to configure entry links (hidden free text question and I used encID as question code), but I still can not figure how to configure end-link.

My entry link is: limesurvey.srce.hr/116421?newtest=Y&lang=sv&encID=test

and I tried this link with panel provider domain blablabla.com

survey.blablabla.com/ic/survey.php?autoAnswer [317950][0]=0&encID={PASSTHRU:encID} and

survey.blablabla.com/?return=complete&encID={PASSTHRU:encID }

as end links but the panel provider says they are not working

Any suggestions?

(My limesurvey is Version 2.67.1+170626)

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
9 months 3 weeks ago #174521 by tpartner
If you have a hidden question try this:

survey.blablabla.com/?return=complete&encID={encID}

(note that you cannot have leading or trailing spaces within the curly braces)

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Official LimeSurvey Partner - partnersurveys.com

Please Log in or Create an account to join the conversation.

More
9 months 3 weeks ago #174645 by ipazur
Replied by ipazur on topic Panel integration -end link
Thank you for a quick replay. We did many tests, with those two end links

survey.blablabla.com/ic/survey.php?autoAnswer [317950][0]=0&encID={PASSTHRU:encID} and

survey.blablabla.com/?return=complete&encID={PASSTHRU:encID}

but so far no luck.

Entry link works fine though... At his point I think panel provider has some security measure from their system which obstructs redirect...

I do not see what else I could do from my side?

Please Log in or Create an account to join the conversation.

More
9 months 3 weeks ago #174649 by holch
Replied by holch on topic Panel integration -end link
What you need to look at is how your END URL looks like when created and see if it is formated as it should. Stop the redirect for now so that you can see how the URL actually looks like and compare it with what it should look like (or ask the panel provider if this URL is OK). From there you can try to fix things. If the URL looks OK to the panel provider, then they need to see why there system doesn't accept it. If it is malformed, then you will have to check what you are doing wrong when creating it.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
9 months 3 weeks ago #174650 by holch
Replied by holch on topic Panel integration -end link
Generally the panel providers give you a couple of URLs to redirect to, depending on the outcome (screenout, quota, complete, etc.). You should also look into that.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
9 months 3 weeks ago #174652 by tpartner

ipazur wrote: Thank you for a quick replay. We did many tests, with those two end links

survey.blablabla.com/ic/survey.php?autoAnswer [317950][0]=0&encID={PASSTHRU:encID} and

survey.blablabla.com/?return=complete&encID={PASSTHRU:encID}

but so far no luck.

Entry link works fine though... At his point I think panel provider has some security measure from their system which obstructs redirect...

I do not see what else I could do from my side?

Why are you still using "PASSTHRU"? As stated in my post, with a hidden question, you don't need it. Did you read the URL I provided?

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Official LimeSurvey Partner - partnersurveys.com

Please Log in or Create an account to join the conversation.

More
9 months 3 weeks ago #174653 by holch
Replied by holch on topic Panel integration -end link
What is also important: Does the "encID" even get passed through correctly?

Maybe do a little test survey with just one question (so you don't have to go through the whole thing to test).

Then create a entry link with the encID and see what the outcome of the END URL is.

Maybe you can attache this little survey as LSS file, so we can try to test.

However, in your situation I would not use passthru, but rather panel integration. This way, you have the encID saved in the database, which does not happen with passthru, as far as I know.

manual.limesurvey.org/URL_fields vs. manual.limesurvey.org/Panel_integration

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
9 months 3 weeks ago - 9 months 3 weeks ago #174705 by ipazur
Replied by ipazur on topic Panel integration -end link
Yes I did try your link survey.blablabla.com/?return=complete&encID={encID} but panel provider said it doesn't work and they told me to use
survey.blablabla.com/ic/survey.php?autoAnswer[317950][0]=0&encID={PASSTHRU:encID}

this is their complete link:
survey.blablabla.com/survey.php?autoAnswer [317950][0]=0&encID=xxx
Last edit: 9 months 3 weeks ago by ipazur.

Please Log in or Create an account to join the conversation.

More
9 months 3 weeks ago #174713 by tpartner
Well, it works for me. See the attached sample survey:

File Attachment:

File Name: limesurvey...6571.lss
File Size:22 KB









Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Official LimeSurvey Partner - partnersurveys.com

Please Log in or Create an account to join the conversation.

More
9 months 3 weeks ago #174714 by holch
Replied by holch on topic Panel integration -end link
Hi Tpartner,

Your LSS did not work for me. I did not receive a value for the encID in the end url.

However, when I looked into the panel integration, there was nothing set! Could you check if in your survey there is the encID set? Because this would mean, that the LSS export does not include the panel integration settings, which I would consider a bug.

So I included a encID in the panel integration settings and now the end URL presents the 12345.

However, no responses were saved in the database. This is really weird.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
9 months 3 weeks ago #174715 by ipazur
Replied by ipazur on topic Panel integration -end link
Thanks but I can not import your file... some internal web server error... but I followed your steps and I am not sure how you get this value 12345 at the end of the link?

My panel provider sent me end link like this
survey.blablabla.com/ic/survey.php?autoAnswer[317950][0]=0&encID={PASSTHRU:encID} ,
if I omit passthru how this link should be configured?

survey.blablabla.com/?return=complete&encID={encID} - now they are saying this one is working... I am confused

Please Log in or Create an account to join the conversation.

More
9 months 3 weeks ago #174716 by holch
Replied by holch on topic Panel integration -end link
Really strange: I tried it several times in normal Chrome. No answer has been recorded, but I always reached the end url and it showed the correct encID. So then I pasted the link into a incognito window on Chrome and suddenly it worked. However, it added something at end of the URL:

www.google.com/?autoAnswer [317950][0]=0&encID=12345&gws_rd=ssl

Tried again in normal chrome, goes through the survey like a charm, but answer is not recorded in the response table.

Does LS prevent answers from a browser where you are logged in as admin???

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
9 months 3 weeks ago #174717 by ipazur
Replied by ipazur on topic Panel integration -end link
Following my last message, here is a test file.
Attachments:

Please Log in or Create an account to join the conversation.

More
9 months 3 weeks ago #174718 by holch
Replied by holch on topic Panel integration -end link

Thanks but I can not import your file... some internal web server error...


Then you have some problems with your installation.

The 12345 is the encID that Tpartner used for test. This needs to be part of the link the panel is sending their participants to.

Thanks but I can not import your file... some internal web server error...

So if this is your survey URL, it would look like this:

yourdomain.com/index.php/646657?lang=en&encID=XXXXX

So the different links would look like:
yourdomain.com/index.php/646657?lang=en&encID=00001
yourdomain.com/index.php/646657?lang=en&encID=00002
yourdomain.com/index.php/646657?lang=en&encID=00003

From this URL the panel integreation reads the encID into a hidden text question which is called "encID" and at the end URL this saved encID is retrieved and included into the end url your participants will be redirected to, so that the panel provider can register if they have completed. Same for the other links that they probably have provided you with for quota, screenouts, etc.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
9 months 3 weeks ago #174719 by holch
Replied by holch on topic Panel integration -end link

Tried again in normal chrome, goes through the survey like a charm, but answer is not recorded in the response table.


Logged out, tried again: response was registered.
Logged in again: response was registered.

Strange. Now it seems to work.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!