Google Maps Api key in older LS(1.92) giving error, tho i've used api-key

More
1 month 3 weeks ago #166591 by LemonWrangler
LemonWrangler created the topic: Google Maps Api key in older LS(1.92) giving error, tho i've used api-key
Hi Great LS-community,

I have had a working survey(LS v=1.92+) 4 years ago with a googlemaps functionality without api key specified. (just opened at a specific place, to put a mark near that location, nothing fancy like searching or distance calculations, etc)

After copying it recently, i got the typical 'MissingKeyMapError'. (The console only mentions 'js?sensor=false' and the like and i cannot seem to find any 'key=MY-KEY' sort of strings, but then again in displaying the error the page changes, so i might not see the original page at load...)
(Actually i got 3 console messages: 1 warning:'SensorNotRequired', 2 warning:'NoApiKeys', 3 ERROR:'MissingKeyMapError')

So after reading up on those messages, i've generated a key at google and inserted it in the Tools->General->Google Maps API key place ( "MY-KEY" , even tried "key=MY-KEY"), but still "no cookie".

Now i've read a claim that LimeSurvey<2.0 uses API v2 and NOT v3. ( uilots-labs.wp.hum.uu.nl/how-to/location-in-limesurvey/ )
How can i check this?

It seems that currently Google only supports v3. So if thats true, how can i make it work (without upgrading to the current LS version)?

Any confirmation of the information above and/or suggestions in fixing this is greatly appreciated!
Cheers

Please Log in or Create an account to join the conversation.

More
1 month 2 weeks ago #166644 by tpartner
tpartner replied the topic: Google Maps Api key in older LS(1.92) giving error, tho i've used api-key
I strongly suggest updating to 2.06 LTS at the very least.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in or Create an account to join the conversation.

More
1 month 2 weeks ago #166855 by LemonWrangler
LemonWrangler replied the topic: Google Maps Api key in older LS(1.92) giving error, tho i've used api-key
Hi Tony,
Thanks for your reply.
Ofc i will upgrade, but trying to NOT do everything all at once, i'd rather fix this googlemaps now for this survey and AFTERWARDS upgrade.
Can you confirm that the older version does use the older (googleMaps)API version 2 (instead of version 3) and that only from 2.0.6 LimeSurvey uses version3 ?
Thanks in advance!

Please Log in or Create an account to join the conversation.

More
1 month 2 weeks ago #166869 by tpartner
tpartner replied the topic: Google Maps Api key in older LS(1.92) giving error, tho i've used api-key
I can say that LimeSurvey 1.92 used API v2. I don't know when the change was made to v3, but 2.05 and newer uses that.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
The following user(s) said Thank You: LemonWrangler

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!