RelevanceEquation for Columns in Array Questions

More
1 month 6 days ago - 1 month 6 days ago #159669 by orvil
orvil created the topic: RelevanceEquation for Columns in Array Questions
Hi, I'm trying to implement an array question (numbers) where the columns of the questions are to hide in some cases using EM.
While working fine for the rows (i.e. subquestions) it does not work even when I am using 1 and 0 for the relevance equation. Tried this with the current stable version and the development version (beta 3) - same problems. Find the screenshots attached.
Any suggestion what I am doing wrong or is this feature not implemented yet?
Thanks
orvil

Best regards/Beste Grüße,
O. Villani
Attachments:
Last Edit: 1 month 6 days ago by orvil.

Please Log in to join the conversation.

More
1 month 6 days ago - 1 month 6 days ago #159671 by Joffm
Joffm replied the topic: RelevanceEquation for Columns in Array Questions
Hello, orvil,

there are several post about this.
It doesn't work at the moment.

You can use instead the plugin "hideemptycolumns"

Download the Demo to understand how it works and the plugin itself.
http://extensions.sondages.pro/hideemptycolumn-for-limesurvey/documentation.html

Regards
Joffm
Last Edit: 1 month 6 days ago by Joffm.
The following user(s) said Thank You: DenisChenu, orvil

Please Log in to join the conversation.

More
1 month 6 days ago #159676 by jelo
jelo replied the topic: RelevanceEquation for Columns in Array Questions

Joffm wrote: there are several post about this.
It doesn't work at the moment.

Interesting. Didn't know that. Are you aware of the main bug report for that issue?
I found this from April 2017.
bugs.limesurvey.org/view.php?id=12277
There is no statement from the developers about the state of this issue.

Please Log in to join the conversation.

More
1 month 5 days ago #159695 by orvil
orvil replied the topic: RelevanceEquation for Columns in Array Questions
Hello Joffm,

thanks for your answer and the workaround. I'll try it with the stable as well as with the dev version!

Anyhow I'm wondering this is not solved for such a long time :(

Regards
Orvil

Best regards/Beste Grüße,
O. Villani

Please Log in to join the conversation.

More
1 month 5 days ago #159696 by orvil
orvil replied the topic: RelevanceEquation for Columns in Array Questions
That long ago. Is it useful to repost the bug?

Regards
Orvil

Best regards/Beste Grüße,
O. Villani

Please Log in to join the conversation.

More
1 month 5 days ago #159698 by orvil
orvil replied the topic: RelevanceEquation for Columns in Array Questions
Hi Joffm,

tried to install the plugin, but failed on stable as well as on development version. Will try it tomorrow again.

Regards
Orvil

Best regards/Beste Grüße,
O. Villani

Please Log in to join the conversation.

More
1 month 5 days ago #159701 by Joffm
Joffm replied the topic: RelevanceEquation for Columns in Array Questions
Yes, I was aware of this bug report.
Tammo posted a reminder there today,

Please Log in to join the conversation.

More
1 month 5 days ago #159707 by Joffm
Joffm replied the topic: RelevanceEquation for Columns in Array Questions
Hi, orvil,
what failrd? The installation of the plugin? Or?

Here the sample survey of Denis.

Regards
Joffm
Attachments:

Please Log in to join the conversation.

More
1 month 5 days ago #159717 by DenisChenu
DenisChenu replied the topic: RelevanceEquation for Columns in Array Questions

orvil wrote: …
tried to install the plugin, but failed on stable as well as on development version. Will try it tomorrow again.

No open issue : framagit.org/SondagePro-LimeSurvey-plugi...deEmptyColumn/issues
The no bug …

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
1 month 2 days ago #159882 by orvil
orvil replied the topic: RelevanceEquation for Columns in Array Questions
Hi DenisChenu,

thanks for answering but unfortunately both attempts failed again - stable as well as beta. In the stable version there is a Yii Debug message as soon as I try to open the plugin administration, saying:

Internal Server Error
Property "CDefaultValueValidator.0" is not defined.

In the beta I get a blank screen instead. Hm, wondering why.

Best regards/Beste Grüße,
O. Villani

Please Log in to join the conversation.

More
3 weeks 5 days ago #160090 by DenisChenu
DenisChenu replied the topic: RelevanceEquation for Columns in Array Questions

orvil wrote: Internal Server Error
Property "CDefaultValueValidator.0" is not defined.

Bug in LimeSurvey fixed just after your release. Need updating

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!