Bug fonction mail - version initial

Más
2 meses 1 semana antes #184192 por twog93
Bonjour,

Une installation "self-hosted" de limesurvey me pose problème.

L'environnement technique : centos-release-7-6.1810., PHP 7.0.33, Apache/2.4.6, mysql 5.6.43, Limesurvey Version 2.65.4

Problème rencontré : fonction mail inopérante à la création de l'utilisateur, renvois mot de passe, validation formulaire, reprise de complétion formulaire.

Logs : Aucun log ne sort


j'ai tenté les différentes méthodes d'envoi d'email , la méthode initiale via php, smtp.... rien n'y fait

auriez-vous des pistes ?

Merci par avance
Gérald

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

LimeSurvey Partners
Más
2 meses 1 semana antes #184197 por DenisChenu
Respuesta de DenisChenu sobre el tema Bug fonction mail - version initial
Ca veut dire que mail n'est pas actif (php_mail).

La méthode actuel de test des mails : au moins pour voir si le serveur tente d'envoyer des mails, c'est la création d'une table d'invitation et l'envoi d'un email.
Active me mode mail debug sur les paramètres avancés.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
2 meses 1 semana antes - 2 meses 1 semana antes #184198 por twog93
Respuesta de twog93 sobre el tema Bug fonction mail - version initial
Merci pour cette réponse, sauf erreur mais la fonction mail php fait partie du coeur de php.

j'ai créer un script d'envois d'email basique pour des fins de test mais je n'ai pas d'erreur php. le "send " semble fonctionner

J'ai déjà activé le mode debug dans le fichier de config. il sort en fichier ou s'affiche à l'exécution du script ?

PS: la machine utilise php fpm et avec un phpinfo() je vois que c'est sendmail qui est configuré, je tente cette approche

merci
Última Edición: 2 meses 1 semana antes por twog93. Razón: update

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
2 meses 1 semana antes #184199 por DenisChenu
Respuesta de DenisChenu sobre el tema Bug fonction mail - version initial
1. Avec ton script : tu recois le mail ?
2.
3. Test avec une table d'invitation : tu aura tous le retour

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .
Adjuntos:

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
2 meses 1 semana antes #184200 por twog93
Respuesta de twog93 sobre el tema Bug fonction mail - version initial
La fonction confirme l'envois mais j'ai rien en réception
PS: la machine utilise php fpm et avec un phpinfo() je vois que c'est sendmail qui est configuré, je tente cette approche

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Más
2 meses 1 semana antes #184210 por DenisChenu
Respuesta de DenisChenu sobre el tema Bug fonction mail - version initial
Bin,

C'est pas parceque la fonction mail est active qu‘elle fonctionne. Le mieux : jeter un oeil sur /var/log/mail.log (ou autre selon).

Ce qui sort du fonctionnement de LimeSurvey …

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .

Por favor, Identificarse o Crear cuenta para unirse a la conversación.

Moderadores: Nickko

¡Comenzar ahora!

Simplemente cree una cuenta y comience a usar LimeSurvey hoy mismo.

Registrarse ahora
¡Únase a nuestro boletín informativo!

Iniciar sesión