Multiple Choice with comments and Array Text filter code

More
1 week 6 days ago #184202 by Elita
Hello, I am creating survey where next following questions contain text entered in the previous Multiple choice Comment and Array Text fields, but cannot get this working.
Could anybody tell me the right syntax?


For Multiple text it is simple code - {J1_J1A1}, where J1 is the question code, J1A1 is the answer code.

Tried different ways - none is working :(

Thank you in advance -
Elita

Please Identificarse or Create an account to join the conversation.

LimeSurvey Partners
More
1 week 5 days ago #184206 by Joffm
Hi, Elita,
please, never forget to mention your LimeSurvey version.

What did you try?


To discover which code to use, the best is to activate your survey and have a look at the answer table.

In a question of type "multiple choice with comments" you will see, that you get two columns for each subquestion:
In your case probably:
1. J1_J1A1
2. J1_J1A1comment

The same with array(text):
Here you have a y-scale and a x-scale:
So the code of a special cell is (depends on your codes):
Q1_Y001_X001,Q1_Y001_X002,Q1_Y001_X003
Q1_Y002_X001,Q1_Y002_X002,Q1_Y002_X003

This way it is easy to find out the codes you like to insert in following questions.

If I misunderstood your question, please clarify and - this is always the best - send a small example as *.lss

Best regards
Joffm


Volunteers are not paid.
Not because they are worthless, but because they are priceless
The following user(s) said Thank You: Elita, cdorin

Please Identificarse or Create an account to join the conversation.

More
1 week 5 days ago #184209 by DenisChenu

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand .
An error happen ? Before make a new topic : remind the Debug mode .
The following user(s) said Thank You: cdorin

Please Identificarse or Create an account to join the conversation.

More
1 week 5 days ago #184216 by Elita
Thank, you, Joffm, for the promt and very clear answer.
Sorry for incomplete question - I am using Version 3.15.9+190214.
Tried those exmples you suggested before too (those worked in the earlier LS versions)and got the error.
By trying that again after your answer everything works.
By my opinion this was because I changed built-in question and answers codes and those codes somehow did not refreshed even though I saved and closed the question.
Everything is working now - thank you again!

Please Identificarse or Create an account to join the conversation.

¡Comenzar ahora!

Simplemente cree una cuenta y comience a usar LimeSurvey hoy mismo.

Registrarse ahora
¡Únase a nuestro boletín informativo!

Iniciar sesión