Welcome, Guest
Username: Password: Remember me

TOPIC: Graphs Fonts

Graphs Fonts 4 years 6 months ago #56310

  • michelk
  • michelk's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
I have search the forum to solve this and I have performed all action but I still can not fix this. My survey is in Greek and all characters are shown ok EXCEPT the graphs characters in the statistics.
I have put the arail.ttf in the fonts directory, I have set the arial.ttf in the config.php file with $chartfontfile = 'arial.ttf'; and still, as you can see in the attachment, I can not get them to display correctly. Any other ideas?
Thanks.


This message has an attachment image.
Please log in or register to see it.

The administrator has disabled public write access.

Graphs Fonts 4 years 2 weeks ago #64552

  • sp00ky
  • sp00ky's Avatar
  • Offline
  • Junior Lime
  • Posts: 25
  • Thank you received: 2
  • Karma: 4
Hello michelk,

I had this same issue. The resolve is to edit classes\pchart\pchart\pChart.class.

$this->setFontProperties("tahoma.ttf",8);
to
$this->setFontProperties("arial.ttf",8);

It worked form me.
The administrator has disabled public write access.

Graphs Fonts 3 years 10 months ago #67254

  • sp00ky
  • sp00ky's Avatar
  • Offline
  • Junior Lime
  • Posts: 25
  • Thank you received: 2
  • Karma: 4
But first of all, clear your browser cache and limesurvey/temp dir (chart pngs are stored there).
The administrator has disabled public write access.

Graphs Fonts 3 years 10 months ago #67256

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5725
  • Thank you received: 333
  • Karma: 255
Please also check that the font type you chose exists.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Graphs Fonts 3 years 9 months ago #68691

  • pirna
  • pirna's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
I' have same problem with spanish characters.



C:\fakepath\sshot-2.png

I've cleaned all temporary folders (windows,user,limesurvey)
I've copyed arial.ttf, tahoma.ttf and verdana.ttf to /fonts folder in limesurvey.
I've changed chartfontfile from "auto" to those in config.php.
I've changed $this->setFontProperties("tahoma.ttf",8); to arial and verdana in classes\pchart\pchart\pChart.class
I've stopped and restarted Apache, and did not works.
Any other idea?
Thanks in advance.

This message has an attachment image.
Please log in or register to see it.

The administrator has disabled public write access.

Graphs Fonts 3 years 9 months ago #68889

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5725
  • Thank you received: 333
  • Karma: 255
I remember that this problem could also be related to some server setting or a server bug but I don't remember the details :-(

Maybe updating your PHP version could also solve the problem.

Maybe Google knows more details?!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.207 seconds