Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: install script gets: error

install script gets: error 4 years 8 months ago #53378

  • twb01
  • twb01's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 11
  • Karma: 0
Attempting to finish a Limesurvey install. When I run install script, I get this error:

Can't connect to LimeSurvey database. Reason: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

(settings: php5; host: media temple, (gs))
Last Edit: 4 years 8 months ago by twb01.
The administrator has disabled public write access.

install script gets: error 4 years 8 months ago #53466

  • twb01
  • twb01's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 11
  • Karma: 0
Additional details: I have installed Limesurvey on numerous other websites over the last few years.

For this project I initially installed ver. 1.9 and after encountering problems, yesterday uninstalled and went back to a previous version from March 2010.

Does anyone have an idea what could be going on here?
The administrator has disabled public write access.

install script gets: error 4 years 8 months ago #53508

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5725
  • Thank you received: 333
  • Karma: 255
What did you set at config.php?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

install script gets: error 4 years 8 months ago #53513

  • twb01
  • twb01's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 11
  • Karma: 0
$databaselocation = 'internal-db.s12345.gridserver.com';
// Network location of your Database - for odbc_mssql use the mssql servername, not localhost or IP

$databasename = 'db12345_limesurvey';
// The name of the database that we will create

$databaseuser = 'db12345';
// The name of a user with rights to create db (or if db already exists, then rights within that db)

$databasepass = '********';
// Password of db user

$dbprefix = 'lime_';
// A global prefix that can be added to all LimeSurvey tables. Use this if you are sharing
// a database with other applications. Suggested prefix is 'lime_'

// File Locations

$rooturl = "http://{$_SERVER}/limesurvey";
// The root web url for your limesurvey installation (without a trailing slash).
// The double quotes (") are important.

$rootdir = dirname(__FILE__);
// This is the physical disk location for your limesurvey installation. Normally you don't have to touch this
// setting. If you use IIS then you MUST enter the complete rootdir e.g. :

$rootDir='C:\Inetpub\wwwroot\limesurvey'!
// Some IIS and OS/2 installations also require to use forward slashes
// instead of backslashes, e.g. $rootDir='C:/Inetpub/wwwroot/limesurvey'!
Last Edit: 4 years 8 months ago by twb01.
The administrator has disabled public write access.

install script gets: error 4 years 8 months ago #53514

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5725
  • Thank you received: 333
  • Karma: 255
What about $databasetype (or whatever that one is called)?

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

install script gets: error 4 years 8 months ago #53515

  • twb01
  • twb01's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 11
  • Karma: 0
Here:
$databasetype = 'mysql';
The administrator has disabled public write access.

install script gets: error 4 years 8 months ago #53519

  • gjh011
  • gjh011's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
I am having exactly the same problem with the same host. I have also install ls numerous times on other hosting services. If you find the solution, please post. Thank you,
The administrator has disabled public write access.

install script gets: error 4 years 8 months ago #53520

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 3690
  • Thank you received: 498
  • Karma: 162
OK, so this sounds like this is a specific problem with media temple. Maybe this helps to find the problem.

As far as I have read, Mediatemple has a very specific configuration for MySQL "Containers", how they call it.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

install script gets: error 4 years 8 months ago #53521

  • gjh011
  • gjh011's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
I am not using containers.
The administrator has disabled public write access.

install script gets: error 4 years 8 months ago #53537

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5725
  • Thank you received: 333
  • Karma: 255
I think I have read about the error message ("Can't connect to LimeSurvey database. Reason: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)") before, please search the forum, you might find a solution there.
Otherwise your ISP's service hotline should be able to help.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.163 seconds