Welcome, Guest
Username: Password: Remember me

TOPIC: Security question image missing PHP Fatal error

Security question image missing PHP Fatal error 4 years 7 months ago #53065

  • pksupport
  • pksupport's Avatar
  • Offline
  • Senior Lime
  • Posts: 40
  • Thank you received: 1
  • Karma: 0
Instead of the security question, I see a ?. I am not sure when this happened but it would be very recent. I upgraded the server (OS X) to 10.6.5 recently. The Apache error log reads:

PHP Fatal Error: Call to undefined function image TTFText() on surveys/verification on line 116

vs 1.90 Build 9169 on OS X Server 10.6.5 PHP vs 5.3.3

I'm really hoping someone has a fix for this as the survey is being used by students. Thanks very much
Last Edit: 4 years 7 months ago by pksupport.
The administrator has disabled public write access.

Security question image missing PHP Fatal error 4 years 7 months ago #53066

  • pksupport
  • pksupport's Avatar
  • Offline
  • Senior Lime
  • Posts: 40
  • Thank you received: 1
  • Karma: 0
Just restarted the server from the 10.6.4 backup. The image works. So it's definitely something in 10.6.5.
The administrator has disabled public write access.

Security question image missing PHP Fatal error 4 years 7 months ago #53176

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5688
  • Thank you received: 329
  • Karma: 255
pksupport wrote:
PHP Fatal Error: Call to undefined function image TTFText() on surveys/verification on line 116
I'm not absolutely sure but this might be caused by a missing library at your PHP configuration.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

Security question image missing PHP Fatal error 4 years 7 months ago #53251

  • pksupport
  • pksupport's Avatar
  • Offline
  • Senior Lime
  • Posts: 40
  • Thank you received: 1
  • Karma: 0
Really appreciate your reply. Yes, 10.6.5 hosed my custom made PHP installation. I installed in the Apple location; evidently I should be building it elsewhere. I fixed this error by recompiling PHP. But it is an issue I will have to deal with. Macports looks very complex. But I can't keep doing the recompile. Thanks anyway.
The administrator has disabled public write access.

Security question image missing PHP Fatal error 4 years 7 months ago #53267

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5688
  • Thank you received: 329
  • Karma: 255
You're welcome!

If our hints have been helpful and you enjoy limesurvey please consider a donation to the team .
We do all this in our free time and you don't have to pay a penny for this software.

Without your help we can't keep this project alive.

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.206 seconds