Welcome, Guest
Username: Password: Remember me

TOPIC: Petit souci d'installation

Petit souci d'installation 2 years 11 months ago #59967

  • aliberlis
  • aliberlis's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 46
  • Karma: 0
Bonjour,

Je viens de faire une installation de Limesurvey.

Tout s’est bien passé, sauf que, au moment de lancer l’interface d’administration, je rentre mon identifiant et mon mot de passe et j’ai une erreur 404.

Je n’ai pas installé Limesurvey à la racine mais dans un dossier /limesurvey.

L’erreur 404 me ramène sur l’URL monsite.free.fr/ admin/admin.php

Je suppose donc que j’ai raté un étage dans la config pour indiquer que Limesurvey était installé sous /limesurvey.

Quelqu’un peut-il me dire :
- Où et ce que je dois modifier (fichier PHP ou table de la base de données)
- Où j’ai raté l’étage dans le fichier config.php au moment de l’installation

Avec tous mes remerciements anticipés

Cordialement

Thierry
The administrator has disabled public write access.

Re: Petit souci d'installation 2 years 11 months ago #59986

  • Nickko
  • Nickko's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 1939
  • Thank you received: 219
  • Karma: 45
"L’erreur 404 me ramène sur l’URL monsite.free.fr/ admin/admin.php"

Ça ce n'est pas vraiment possible à moins d'avoir modifier les pages d'erreur 404.

Tu vois bien un message qui te parle d'erreur 404 ?
Tu pourrais nous donner une copie d'écran pour qu'on identifie bien le problème ?
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.

Re: Petit souci d'installation 2 years 11 months ago #59988

  • aliberlis
  • aliberlis's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 46
  • Karma: 0
Bonjour, et merci de t'intéresser à mon souci.

Je t'adresse en PJ :
- une image de ma page Login (voir URL en haut)
- une image de ma page 404 de Free (voir également URL)

L'erreur 404 est logique au regard de l'URL, car LS ne va pas au bon endroit pour lancer l'admin.php. Il va le chercher dans /admin, alors qu'il devrait aller dans /limesurvey/admin

D'où ma conclusion que j'ai du me vautrer dans la config initiale en oubliant d'indiquer quelque part que LS se trouve dans /limesurvey, et pas dans /

J'aimerais pouvoir rectifier sans avoir à refaire une install complète, et surtout savoir où je me suis loupé.

Merci de votre aide et bonne journée à tous.

Cordialement

Thierry

Page Login

login.jpg



Page erreur 404

404.jpg
The administrator has disabled public write access.

Re: Petit souci d'installation 2 years 11 months ago #59989

  • Nickko
  • Nickko's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 1939
  • Thank you received: 219
  • Karma: 45
Ok, là je pense à un mauvais transfert de fichier, essaie de transférer les fichiers de Limesurvey (en gros réinstallation sommaire).
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.

Re: Petit souci d'installation 2 years 11 months ago #59991

  • aliberlis
  • aliberlis's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 46
  • Karma: 0
Nickko,

J'ai déjà tout vérifié au niveau des fichiers : le répertoire /admin est bien présent avec tous ses fichiers dans /limesurvey

D'ailleurs, tu vois bien en regardant le 2ème écran que l'URL ne va pas dans /limesurvey/admin mais dans /admin.

Je me souviens bien avoir lu qu'il fallait indiquer le chemin du répertoire de limsesurvey s'il n'est pas directement sous la racine.

Mais lu où ... ?
The administrator has disabled public write access.

Re: Petit souci d'installation 2 years 11 months ago #59992

  • Nickko
  • Nickko's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 1939
  • Thank you received: 219
  • Karma: 45
Qu'as-tu dans config.php en face des variable rootdir et rooturl ?
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.

Re: Petit souci d'installation 2 years 11 months ago #59996

  • aliberlis
  • aliberlis's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 46
  • Karma: 0
J'ai ce qu'il y avait pas défaut : il est probable que c'est là que j'aurais du intégrer le /limesurvey.

Est-ce que si je rajoute cela (/limesurvey) dans le config.php, cela fonctionnera correctement ?

Et si oui, selon quelle syntaxe exactement ?

Actuellement, il y a :
$rooturl = "http://{$_SERVER}";
$rootdir = dirname(__FILE__);

Que-dois-je modifier pour dire à LS qu'il se trouve dans /limesurvey ?
The administrator has disabled public write access.

Re: Petit souci d'installation 2 years 11 months ago #60009

  • aliberlis
  • aliberlis's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 46
  • Karma: 0
Bonsoir,

J'ai procédé à la modif suivante dans le config.php, à savoir que j'ai ajouté limesurvey dans la ligne suivante :
$rooturl = "http://{$_SERVER}/limesurvey";

Maintenant, j'accède bien à l'administration.

Faut-il que je modifie également la ligne suivante ?
$rootdir = dirname(__FILE__);

Si oui, avec quelle syntaxe pour intégrer /limesurvey (si nécessaire bien sûr !)

Cordialement

Thierry
The administrator has disabled public write access.

Re: Petit souci d'installation 2 years 11 months ago #60010

  • Nickko
  • Nickko's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 1939
  • Thank you received: 219
  • Karma: 45
Si ça marche comme ça ne touche à rien ;-)
Nickko
Ergonome / Usability expert
The administrator has disabled public write access.
The following user(s) said Thank You: aliberlis

Re: Petit souci d'installation 2 years 11 months ago #60011

  • aliberlis
  • aliberlis's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 46
  • Karma: 0
En tout cas, merci pour ton aide.

Bonne soirée.

Thierry
The administrator has disabled public write access.
Moderators: Nickko
Time to create page: 0.120 seconds
Donation Image