Welcome, Guest
Username: Password: Remember me

TOPIC: Session Timeout not working

Session Timeout not working 3 years 5 months ago #52054

  • sumitmalik
  • sumitmalik's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Hi,

I've set the session timeout to 60 seconds (just for testing, I want it to be 3600). But the system is not timeouting me.

I've even uncommented the line:

@ini_set('session.gc_maxlifetime', $sessionlifetime);

But no help. I ever tried changing the session.gc_maxlifetime value in php.ini and restarted the server too, but its still not timeouting me.

Any help?
The administrator has disabled public write access.

Re:Session Timeout not working 3 years 5 months ago #52055

  • Mazi
  • Mazi's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 5279
  • Thank you received: 289
  • Karma: 246
I don't think this is a Limesurvey issue. Even if you set a limit in Limesurvey, this limit might be ignored/get overwritten by global webserver settings.
The timeout usually works correctly, this is being confirmed by users complaining about running into timeouts.

If you still think it's a bug:
Please test if the problem still exists at the latest release. If so please open a ticket at the bugtracker and...

1. Give as much information as possible

2. Attach your survey. You can mark your ticket "private" so that only the developers will be able to take a look at it.

3. Provide step-by-step instructions how to reproduce the problem.

4. If possible/helpful please provide screenshots

Afterwards please post the link to the bugtracker so we can follow the progress.

Thanks!

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.097 seconds
Donation Image