Welcome, Guest
Username: Password: Remember me

TOPIC: Inserting HTML5 source only works for super admins?

Inserting HTML5 source only works for super admins? 11 months 4 weeks ago #95090

Hi,

I'm using Version 2.00+ Build 130406.

I have a user who would like to insert video clips into her survey. (And, considering where I work, I expect a LOT more requests for video in questions, answers, and elsewhere.) I did a quick test, creating a survey with HTML5 <video>, <source>, <track> tags, and all went well. However when she tried, it happily stripped out all of that.

Is this a user rights issue that can be solved without giving her the keys to the entire kingdom?
The administrator has disabled public write access.

Inserting HTML5 source only works for super admins? 11 months 4 weeks ago #95102

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 3813
  • Thank you received: 683
  • Karma: 328
That may be a bug. In my opinion, the global "Filter HTML for XSS" setting should be, well, global.

Please file a bug report and post the link to the bug here so we can follow the progress.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Inserting HTML5 source only works for super admins? 11 months 3 weeks ago #95127

To misquote the American automated phone system:

"Beep-beep-beep.
The link you provided, www.limesurvey.org/en/support/bug-tracker, yields a 404.
The new number is bugs.limesurvey.org/my_view_page.php
Please make a note of it."
The administrator has disabled public write access.

Inserting HTML5 source only works for super admins? 11 months 3 weeks ago #95128

Now filed as bug 7781.

bugs.limesurvey.org/view.php?id=7781
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.102 seconds
Donation Image