Welcome, Guest
Username: Password: Remember me

TOPIC: Conditions & style issues

Conditions & style issues 2 years 8 months ago #63993

  • eryan07
  • eryan07's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Hello,

My name is Eric Birnie and I am currently a web development intern with a company here in RI. We have chosen to use Limesurvey for a project that we are working on. I have successfully designed and developed a custom template and imported all our questions. However, I am having two issues that are preventing us from finishing this project.

1) I am unable to set conditions for a particular group of questions. All other conditions work; however, when I go to set conditions on any questions in this group, I get no predefined answers to select from.

2) I am getting a weird issue with styling the position of the asterisk symbol. Some questions it appears correctly, but with others that are the same question type, it is positioned wrong. It seems my first 9 questions appear correctly, but the rest are wong.

Thank you for your help,
The administrator has disabled public write access.

Re: Conditions & style issues 2 years 8 months ago #64014

  • greg_d
  • greg_d's Avatar
  • OFFLINE
  • Senior Lime
  • Posts: 47
  • Thank you received: 7
  • Karma: 4
Hi,

(1) If there is no predefined answers to select from it may be this bug: bugs.limesurvey.org/view.php?id=5355

(2) Could you please attach some screenshots of correct and incorrect position of aterisk?
The administrator has disabled public write access.

Re: Conditions & style issues 2 years 8 months ago #64020

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 3837
  • Thank you received: 688
  • Karma: 330
(2) Could you please attach some screenshots of correct and incorrect position of aterisk?
And maybe a link to a sample survey so we can see the source and styles.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Re: Conditions & style issues 2 years 8 months ago #64031

  • eryan07
  • eryan07's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Thank you for your help. Here are two screen shots. Both are same question type, yet displaying differently.
xzitotest.com/survey/index.php?sid=21781&lang=en

Also, I have run into another dilemma. I followed the steps online to create a fav icon and edited the header file. My fav icon works great in Chrome, but does not display at all in firefox. Is this a browser issue or is there a conditional code that I can add to get the favicon to show in Firefox?

Thanks again,
Eric
Attachments:
The administrator has disabled public write access.

Re: Conditions & style issues 2 years 8 months ago #64032

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 3837
  • Thank you received: 688
  • Karma: 330
I suspect that the second example has the question text wrapped in a <p> element which is causing the line-wrap. Check the source of that question.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Re: Conditions & style issues 2 years 8 months ago #64034

  • eryan07
  • eryan07's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
:) Thank you so much issue resolved. Any idea about the fav icon issue?
The administrator has disabled public write access.

Re: Conditions & style issues 2 years 8 months ago #64035

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 3837
  • Thank you received: 688
  • Karma: 330
Did you:

1) Name the favicon "favicon.ico"?

2) Place it in your template directory?

3) Add the following script to the <head> element in startpage.pstpl?
<link rel="shortcut icon" href="{TEMPLATEURL}favicon.ico" />
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.
The following user(s) said Thank You: eryan07
Moderators: ITEd
Time to create page: 0.138 seconds
Donation Image