Welcome, Guest
Username: Password: Remember me

TOPIC: multi numeric - slider, inital value dont register

multi numeric - slider, inital value dont register 3 years 10 months ago #66717

  • lovepade
  • lovepade's Avatar
  • Offline
  • Expert Lime
  • Posts: 93
  • Karma: 0
Well - I'll donate even if it takes more then 24 hours :-) I just hope I can have it working locally by sunday evening. Otherwise I must change the survey. Thanks for all the effort and attention you are putting in to this.
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 3 years 10 months ago #66732

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5725
  • Thank you received: 334
  • Karma: 255
I first (untested) fix was just released. You can test the updated file here: limesurvey.svn.sourceforge.net/viewvc/li...ision&revision=11094

Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 3 years 10 months ago #66735

  • lovepade
  • lovepade's Avatar
  • Offline
  • Expert Lime
  • Posts: 93
  • Karma: 0
Fantastic news. I'll test it right away. Basically I'll just overwrite the old qanda.php?
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 3 years 10 months ago #66736

  • lovepade
  • lovepade's Avatar
  • Offline
  • Expert Lime
  • Posts: 93
  • Karma: 0
Okay - thanks. We are almost - but not quite there.

the issue with persistency / registration of the initial value seems to be resolved. But something has messed up the slider design. Se attached screenshot: Theres is an inputbox visible where there should only be a slider? I hope this explanation makes sense?
Attachments:
Last Edit: 3 years 10 months ago by lovepade.
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 3 years 10 months ago #66739

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5106
  • Thank you received: 1049
  • Karma: 440
I don't see that with the fix in IE or Firefox. Do you have any custom scripts running?

Can you please try with the attached survey in the default template?

File Attachment:

File Name: limesurvey...2781.lss
File Size:34 KB



This message has an attachment image.
Please log in or register to see it.

This message has an attachment file.
Please log in or register to see it.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 3 years 10 months ago #66740

  • lovepade
  • lovepade's Avatar
  • Offline
  • Expert Lime
  • Posts: 93
  • Karma: 0
Well - yes I still see the input boxes? just tried on firefox 7 and chrome 16. (mac os x).

Weird.

EDIT: I just got home and tried on chrome stable, linux. Still the input boxes show up. I tried with default template, limespired and eirenicon.

This is the culprit:
<input class="text" type="text" name="42781X224X27011" id="answer42781X224X27011" value="25"
">

I guess I can hide the input box with e.g.
#answer42781X224X27011 {
    display: none;
}
... but it's not very elegant :-)
Last Edit: 3 years 10 months ago by lovepade. Reason: codefix
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 3 years 10 months ago #66743

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5106
  • Thank you received: 1049
  • Karma: 440
Can you activate a sample survey for me to test?
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 3 years 10 months ago #66764

  • lovepade
  • lovepade's Avatar
  • Offline
  • Expert Lime
  • Posts: 93
  • Karma: 0
Hi tpartner,
I'd be glad to. This is the your own test survey, with the limespired template. skema.dzidzo.dk/42781/lang-en
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 3 years 10 months ago #66768

  • Mazi
  • Mazi's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5725
  • Thank you received: 334
  • Karma: 255
Using the linked test survey I can reproduce the problem on Firefox 3.6:

This message has an attachment image.
Please log in or register to see it.


Best regards/Beste Grüße,
Dr. Marcel Minke
(Limesurvey Head of Support)
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)limesurvey.org'"
The administrator has disabled public write access.

multi numeric - slider, inital value dont register 3 years 10 months ago #66785

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5106
  • Thank you received: 1049
  • Karma: 440
This is very odd, I can't reproduce this with the latest release (11102).

Marcel, can you reproduce on your system?

lovepade, did you update your whole <a href='www.docs.limesurvey.org/tiki-index.php?p...tions+for+LimeSurvey'>installation</a> or just quanda.php?

This is what I see:

This message has an attachment image.
Please log in or register to see it.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
Last Edit: 3 years 10 months ago by tpartner.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.176 seconds