Welcome, Guest
Username: Password: Remember me
  • Page:
  • 1
  • 2

TOPIC: Response Table ID Number

Response Table ID Number 4 years 4 months ago #59722

  • jumper1449
  • jumper1449's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Hello,

I have sent out a survey and starting to get responses. In the response data table the ID numbers run in order but only start at 6. I am wondering how I locate ID numbers 1-5? I was told that 1-5 were missing due to testing however, I re-sent the survey to myself (since I did during testing too) and my response did not come back as an ID number between 1 and 5.

I am working with version 1.85+ and very new all of this.
The administrator has disabled public write access.

Response Table ID Number 4 years 4 months ago #59728

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 3704
  • Thank you received: 501
  • Karma: 162
I would also guess that those ID's where used during testing and later deleted, otherwise they should show up in the statistics section. Do you have maybe a screenshot or something?
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Response Table ID Number 4 years 4 months ago #59745

  • jumper1449
  • jumper1449's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
I cant do a screen shot but it basically looks like this.

id
6
7
8
9
10
The administrator has disabled public write access.

Response Table ID Number 4 years 4 months ago #59749

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 3704
  • Thank you received: 501
  • Karma: 162
The first 5 must have been deleted by someone using your installation. Probably those were links that have been tested, etc.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Response Table ID Number 4 years 4 months ago #59750

  • jumper1449
  • jumper1449's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 3
  • Karma: 0
Ok. Is there anyway I can recover those links without deactivating the survey?
The administrator has disabled public write access.

Response Table ID Number 4 years 4 months ago #59751

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 3704
  • Thank you received: 501
  • Karma: 162
Hmm, I have no idea. I fear, when they were actually deleted, then there might be no chance to get them back. But this very much depends on what exactly happened to them. At the moment it is not 100% clear to me.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

Response Table ID Number 1 week 1 day ago #124042

I have a similar question. The IDs in my response table look like this:

id
25
26
27
28
29
30
32
579
34
35
41
37
580
38
39
40
42
43
44
45
46

As you can see, some ids are missing (1-24, 31, 33, 36) others don't appear in the correct order (41, 579, 580). Any idea what could be causing this?
The administrator has disabled public write access.

Response Table ID Number 1 week 21 hours ago #124079

  • tammo
  • tammo's Avatar
  • Offline
  • Gold Lime
  • Posts: 175
  • Thank you received: 27
  • Karma: 6
Maybe this has to do with working with an ancient version of LimeSurvey. 1.85 is from years ago. Please try reproduce this behaviour in a newer version.

Tammo ter Hark
Tools for Research
Haarlem/Amsterdam, The Netherlands
The administrator has disabled public write access.

Response Table ID Number 1 week 21 hours ago #124080

  • jelo
  • jelo's Avatar
  • Online
  • Platinum Donor
  • Posts: 876
  • Thank you received: 93
  • Karma: 30
tammo wrote:
Maybe this has to do with working with an ancient version of LimeSurvey. 1.85 is from years ago. Please try reproduce this behaviour in a newer version.
The poster hasn't stated which version is in the use.

There are few reasons, why the counter is showing such gaps.
Deactivating and activating the survey. Deleting answers. Reimporting Data.
Sometime the database configuration is forcing the counter to jump.
Mostly such issues can be ignored. As long as the ID isn't going backwards or a ID is occurring two times, it won't cause much trouble.
The administrator has disabled public write access.

Response Table ID Number 1 week 18 hours ago #124094

Thanks for the replies. I'm on version 2.05+ build 141229.

Deactivating and reactivating the survey could account for the 24 missing IDs at the beginning. No answers were deleted and I didn't reimport any data. I don't know how my database configuration could cause the counter to jump.

It's probably a non-issue. The IDs aren't going backwards and no ID is occuring more than once. Apart from the jumps in the IDs, the data seems to be fine.
Last Edit: 1 week 18 hours ago by Oldencastle. Reason: Typo
The administrator has disabled public write access.
  • Page:
  • 1
  • 2
Moderators: ITEd
Time to create page: 0.293 seconds