Welcome, Guest
Username: Password: Remember me

TOPIC: Statistics

Statistics 4 years 4 months ago #59244

  • squeak24
  • squeak24's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
Hi

I have my Limesurvey in a Greybox iFrame, I have got it working all the way through the survey to where you submit it, but now I have a couple of issues. I am using the mint_idea template.

1. When I click on the statistics page, this opens in a blank page, but I want to keep this in the iFrame. What page do I need to edit to make this happen.

2. When I click on the statistics, even though I have asked these to be public, it is not showing up with any stats. Does anyone know what the issue may be?

Any help would be greatly appreciated.

;)
The administrator has disabled public write access.

Statistics 4 years 4 months ago #59245

  • squeak24
  • squeak24's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
OK, I think I know what the second problem is, I think it is that I haven't set any of the questions to be available in the public stats, so it is just the problem one that I am having issues with.

Any help would be appreciated.
The administrator has disabled public write access.

Statistics 4 years 4 months ago #59247

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5101
  • Thank you received: 1049
  • Karma: 440
You should be able to do it without hacking the core code.

Add the following to the end of template.js:
$(document).ready(function(){  
 
		$('a.publicstatisticslink').attr('target', '_self');
 
	});
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.
The following user(s) said Thank You: squeak24

Statistics 4 years 4 months ago #59256

  • squeak24
  • squeak24's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 8
  • Karma: 0
tpartner wrote:
You should be able to do it without hacking the core code.

Add the following to the end of template.js:
$(document).ready(function(){  
 
		$('a.publicstatisticslink').attr('target', '_self');
 
	});

Thank you, that has worked brilliantly.
The administrator has disabled public write access.

Statistics 4 years 4 months ago #59281

  • adihar
  • adihar's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 1
  • Karma: 0
Hi. I'm new and just installed the poll.

My question, when click statistic, it just showed "Total records in survey" and no statistic.

In 'Presentation and Navigation' menu, I already check yes to all.

Please help. Thanks
The administrator has disabled public write access.

Statistics 4 years 4 months ago #59286

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5101
  • Thank you received: 1049
  • Karma: 440
For each question you want to show in public statistics, you need to select "Yes" for "Show in public statistics" in the Advanced Question Settings.

This message has an attachment image.
Please log in or register to see it.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.148 seconds