Welcome, Guest
Username: Password: Remember me

TOPIC: "*" before every question

"*" before every question 4 years 10 months ago #50217

  • servey
  • servey's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
Hi guys, Do you know how i can get rid of the * before my questions using the mint idea based theme?
Looked in the coding and cant find it anywhere.

Thanks

This message has an attachment image.
Please log in or register to see it.

The administrator has disabled public write access.

"*" before every question 4 years 10 months ago #50218

  • jelo
  • jelo's Avatar
  • Offline
  • Platinum Donor
  • Posts: 867
  • Thank you received: 93
  • Karma: 29
docs.limesurvey.org/tiki-index.php?page=...mandatory_questions_
* Open the template editor
    * Create a copy of the template you wish to modify
    * Select the "template.css" file and search for the asterix class
    * Add the following line at the end of the asterix class".asterisk {display: none;}".
    * Save template.css
    * Clear your browser cache so that the edited template.css is reloaded and not taken from cache.
Last Edit: 4 years 10 months ago by jelo.
The administrator has disabled public write access.

"*" before every question 4 years 10 months ago #50219

  • servey
  • servey's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
Do I search for "*"?
The administrator has disabled public write access.

"*" before every question 4 years 10 months ago #50221

  • jelo
  • jelo's Avatar
  • Offline
  • Platinum Donor
  • Posts: 867
  • Thank you received: 93
  • Karma: 29
You search for "asterisk".
The administrator has disabled public write access.

"*" before every question 4 years 10 months ago #50223

  • servey
  • servey's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
I have searched for asterisk and it says not found on all my css sheets
The administrator has disabled public write access.

"*" before every question 4 years 10 months ago #50225

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 3682
  • Thank you received: 498
  • Karma: 162
OK, it seems like mint_idea doesn't have a class "asterisk" defined in the stylesheet. But the class is in the question.pstpl:
<span class="asterisk">{QUESTION_MANDATORY}</span>

So what you do is to create a class in the template.css and hide this class:
.asterisk {
display:none;
}

Or you could just remove the whole code above, so the asterisk doesn't show anymore. However, just to inform you: the asterisk is there to alert participants about mandatory questions. If you hide/delete it, there is no sign of the question being mandadory.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

"*" before every question 4 years 10 months ago #50232

  • jelo
  • jelo's Avatar
  • Offline
  • Platinum Donor
  • Posts: 867
  • Thank you received: 93
  • Karma: 29
If there is no asterisk defined in the css why is it then shown ;-)

Perhaps servey should read the linked stuff and if he/she still don't get rid of the red asterisk he/she should tell us which version build of limesurvey is used.
The administrator has disabled public write access.

"*" before every question 4 years 10 months ago #50239

  • servey
  • servey's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 10
  • Karma: 0
Thank-you. That worked
The administrator has disabled public write access.

"*" before every question 4 years 10 months ago #50242

  • holch
  • holch's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 3682
  • Thank you received: 498
  • Karma: 162
@Jelo: it shows, because it is included in question.pstpl.

But the class "asterisk" is not available in my template.css of mint_idea. Have a look at yours if it is there. Would be weired.
Have a look at the manual! It is a really valuable source for information. Here some helpful links:
Manual (EN) | Question Types | Question Attributes | Workarounds

If you found this answer helpful and it saved you some time please consider a donation to the project to keep Limesurvey going!
The administrator has disabled public write access.

"*" before every question 4 years 10 months ago #50290

  • Grenadeh
  • Grenadeh's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 14
  • Karma: 0
I did exactly what the previous person was told to do (as there is no asterisk class in my template either) and this did not get rid of the asterisk.

Nevermind, I fixed it. For whatever reason none of the classes are defined in the template, they are in the startpage.pstpl
Last Edit: 4 years 10 months ago by Grenadeh.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.145 seconds