Welcome, Guest
Username: Password: Remember me

TOPIC: Unnecessary Span in the end message box

Unnecessary Span in the end message box 1 year 7 months ago #103032

  • mrli999
  • mrli999's Avatar
  • Offline
  • Expert Lime
  • Posts: 95
  • Thank you received: 2
  • Karma: 0
I hope to display the score I got using EM in the end message. And it did apprear,just like the following 1.8. However there also apprear a unneceesary span,just ilike: <span id='LEMtailor_Q_0_11'>1.8</span>

I don't want that span. How can I delete it?

Original code:
<p> <img alt="" src="www.abcdefg.com/result/examples/new3.php...;d=5&e=3&f=6" style="width: 700px; height: 230px;" /></p>

However the output

<p> <img alt="" src="www.abcdefg.com/result/examples/new3.php?a=<span id='LEMtailor_Q_0_11'>1.8</span>&b=2&c=3&d=5&e=3&f=6" style="width: 700px; height: 230px;" /></p>
Last Edit: 1 year 7 months ago by mrli999.
The administrator has disabled public write access.

Unnecessary Span in the end message box 1 year 7 months ago #103039

  • mrli999
  • mrli999's Avatar
  • Offline
  • Expert Lime
  • Posts: 95
  • Thank you received: 2
  • Karma: 0
I got five scores through EM, and I would like pass those five scores to another php page. what should I do in the end message box?
The administrator has disabled public write access.

Unnecessary Span in the end message box 1 year 7 months ago #103042

  • DenisChenu
  • DenisChenu's Avatar
  • Offline
  • Moderator Lime
  • Posts: 7495
  • Thank you received: 1021
  • Karma: 296
What is your LimeSurvey version and build number ?
The administrator has disabled public write access.
The following user(s) said Thank You: mrli999

Unnecessary Span in the end message box 1 year 7 months ago #103050

  • mrli999
  • mrli999's Avatar
  • Offline
  • Expert Lime
  • Posts: 95
  • Thank you received: 2
  • Karma: 0
DenisChenu wrote:
What is your LimeSurvey version and build number ?

2.05,131219
The administrator has disabled public write access.

Unnecessary Span in the end message box 1 year 7 months ago #103074

  • tpartner
  • tpartner's Avatar
  • Online
  • LimeSurvey Team
  • Posts: 5087
  • Thank you received: 1046
  • Karma: 438
Hmm...I can't reproduce that problem.

Here is a small survey that pipes the value of an equation question into the src attribute of an image in the end message. Can you test with this sample?

File Attachment:

File Name: limesurvey...8692.lss
File Size:13 KB

This message has an attachment file.
Please log in or register to see it.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.
The following user(s) said Thank You: mrli999

Unnecessary Span in the end message box 1 year 7 months ago #103079

  • mrli999
  • mrli999's Avatar
  • Offline
  • Expert Lime
  • Posts: 95
  • Thank you received: 2
  • Karma: 0
tpartner wrote:
Hmm...I can't reproduce that problem.

Here is a small survey that pipes the value of an equation question into the src attribute of an image in the end message. Can you test with this sample?

File Attachment:

File Name: limesurvey...8692.lss
File Size:13 KB

Dear Tpartner,

Thank you very much for your help. some additional information:
1. I use all in one model.

2.I calculate 6 scores through EM.

3.It seems the same problem as: bugs.limesurvey.org/view.php?id=8323. Sometimes ok, sometimes apprear.
The administrator has disabled public write access.

Unnecessary Span in the end message box 1 year 7 months ago #103100

  • tpartner
  • tpartner's Avatar
  • Online
  • LimeSurvey Team
  • Posts: 5087
  • Thank you received: 1046
  • Karma: 438
Oh, now I see - the problem only appears in "all-in-one" mode.

I'm not sure it's related to bug 8323 so I opened a new one - bugs.limesurvey.org/view.php?id=8509. Please add to the bug as you see fit.

.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
Last Edit: 1 year 7 months ago by tpartner.
The administrator has disabled public write access.
The following user(s) said Thank You: DenisChenu, mrli999

Unnecessary Span in the end message box 1 year 7 months ago #103290

  • tpartner
  • tpartner's Avatar
  • Online
  • LimeSurvey Team
  • Posts: 5087
  • Thank you received: 1046
  • Karma: 438
This will be fixed in the next 2.05 release (tomorrow?).

bugs.limesurvey.org/view.php?id=8509

.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.156 seconds