Welcome, Guest
Username: Password: Remember me

TOPIC: Lime not sending out notifications

Lime not sending out notifications 7 months 3 weeks ago #99307

  • alecabral
  • alecabral's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Hi guys!
I am new to LimeSurvey. Just got it installed on my server and I already have my first survey going on. The one thing I haven't been able to figure out is the notification thing: I need to get notifications each time someone completes the survey. I'm using gmail as my email service, so I completed the global email notification area with gmail info.

Current SMTP: smtp.gmail.com:25 with SSL, SMTP debug off. The rest of the info is there (user and pass), but I don't think it's even sending emails.

I also accessed the email templates part of the survey, and this is what I see (see image attached).

h8b5c245.png


I noticed the "Detailed admin notification email" appears blank. i figured that's the problem but I don't know.

Can you please confirm what's wrong? what can I do to fix it?

Thanks!
The administrator has disabled public write access.

Lime not sending out notifications 7 months 2 weeks ago #99406

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 3813
  • Thank you received: 683
  • Karma: 328
On most servers you can use the default PHP Mailer instead of SMTP:
hb608da0.JPG



You will need to place your email address in one of the notification email fields:
hb918031.JPG
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Lime not sending out notifications 7 months 2 weeks ago #99410

  • alecabral
  • alecabral's Avatar
  • OFFLINE
  • Fresh Lemon
  • Posts: 2
  • Karma: 0
Hi Tony,
Thanks for your reply! I had tried that already but it didn't work. I reverted back to it just in case so I could try once more but it did nothing. mailer is back to PHP (default), I just completed the survey again but no notifications came out.

Is there anything on the server I should be checking for that php mailer to work?

Thanks,
Alejandro
The administrator has disabled public write access.

Lime not sending out notifications 7 months 2 weeks ago #99478

  • tpartner
  • tpartner's Avatar
  • OFFLINE
  • LimeSurvey Team
  • Posts: 3813
  • Thank you received: 683
  • Karma: 328
Unfortunately, I'm not a server expert. Perhaps someone with more knowledge in that area could answer.
Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Lime not sending out notifications 7 months 2 weeks ago #99488

  • jelo
  • jelo's Avatar
  • OFFLINE
  • Platinum Lime
  • Posts: 389
  • Thank you received: 40
  • Karma: 15
What did you get as error message when activating the debug mode?

Make sure that you use the correct email address of your gmail account as Admin E-Mail.

Try to use "smtp.gmail.com:465" with SSL .

Make sure that the complete username is used for the smtp server: This email address is being protected from spambots. You need JavaScript enabled to view it.
The administrator has disabled public write access.

Lime not sending out notifications 7 months 2 weeks ago #99515

  • DenisChenu
  • DenisChenu's Avatar
  • NOW ONLINE
  • Moderator Lime
  • Posts: 5837
  • Thank you received: 713
  • Karma: 222
Hi,

Did you have access to server log ? Can you set "emailsmtpdebug" to 1 in your application/config/config.php file.
'config'=>array(
		'debug'=>2,
                 'emailsmtpdebug'=>1
		'debugsql'=>0 // Set this to 1 to enanble sql logging, only active when debug = 2
	)


Denis

PS:tpartner wrote:
Unfortunately, I'm not a server expert. Perhaps someone with more knowledge in that area could answer.
Hi Tony, it same think like other : get the log/debug ;).
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.184 seconds
Donation Image