Welcome, Guest
Username: Password: Remember me

TOPIC: Multiple completions with one token - in version 1.91

Multiple completions with one token - in version 1.91 4 years 2 months ago #61821

  • lstrange
  • lstrange's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 15
  • Karma: 0
I have a user that wants to be able to do multiple completions with one token. They found this workaround for version 1.71 here:

docs.limesurvey.org/tiki-index.php?page=..._with_only_one_token

but I just installed Version 1.91 Build 10120 on a test server and this portion of code is different, so I'm not quite sure how to make the changes for version 1.91.

The section of new code appears like this:

///////

elseif (bIsTokenCompletedDatestamped($thissurvey))
{
if (isset($usesleft) && $usesleft<=1)
{
$utquery .= "SET usesleft=usesleft-1, completed='$today'\n";
}
else
{
$utquery .= "SET usesleft=usesleft-1\n";
}
}
else
{
if (isset($usesleft) && $usesleft<=1)
{
$utquery .= "SET usesleft=usesleft-1, completed='Y'\n";
}
else
{
$utquery .= "SET usesleft=usesleft-1\n";
}
}

/////

Any ideas? Appreciate it.

Lainie
The administrator has disabled public write access.

Multiple completions with one token - in version 1.91 4 years 2 months ago #61822

  • tpartner
  • tpartner's Avatar
  • Offline
  • LimeSurvey Team
  • Posts: 5088
  • Thank you received: 1046
  • Karma: 438
I don't think you need the hack for 1.91. You can add multiple uses to the tokens. Note that "Enable token-based response persistence?" must be set to "No".

This message has an attachment image.
Please log in or register to see it.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

LimeSurvey is open-source and run entirely by volunteers so please consider donating to support the project.
The administrator has disabled public write access.

Multiple completions with one token - in version 1.91 4 years 2 months ago #61824

  • lstrange
  • lstrange's Avatar
  • Offline
  • Fresh Lemon
  • Posts: 15
  • Karma: 0
That worked! Thank you!
The administrator has disabled public write access.
Moderators: ITEd
Time to create page: 0.145 seconds