Willkommen, Gast
Benutzername: Passwort: Angemeldet bleiben:
  • Seite:
  • 1
  • 2

THEMA: Pas d'option pour installer 2.00+ sur MS-SQL?!

Pas d'option pour installer 2.00+ sur MS-SQL?! 10 Monate 4 Wochen her #96274

  • mas_carpone
  • mas_carpones Avatar
  • OFFLINE
  • Expert Lime
  • Beiträge: 86
  • Dank erhalten: 4
  • Karma: 0
Bonjour,

Je viens de recevoir un coup de fil de mon collègue IT qui m'indique que lors de l'install, la seule option disponible est MY-SQL?!!

Est-ce le cas? Et si non d'ou peut provenir ce problème?

(NB: On souhaite passer sous MySQL mais certains de nos systèmes sont en exploitation donc on a repoussé cette option pour l'instant...)
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Pas d'option pour installer 2.00+ sur MS-SQL?! 10 Monate 4 Wochen her #96275

  • DenisChenu
  • DenisChenus Avatar
  • OFFLINE
  • Moderator Lime
  • Beiträge: 5854
  • Dank erhalten: 716
  • Karma: 222
Il me semble que l'installateur vérifie la disponibilité des bases de données via php.

Il y a sans doute un module php-mssql à installer.

Denis
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Pas d'option pour installer 2.00+ sur MS-SQL?! 10 Monate 4 Wochen her #96279

  • mas_carpone
  • mas_carpones Avatar
  • OFFLINE
  • Expert Lime
  • Beiträge: 86
  • Dank erhalten: 4
  • Karma: 0
Aouch', merci Denis.

Ca à l'air benin mais je crains que ca ne ralentisse le process ici (mon collègue est pas mal débordé et tout cailloux dans la chaussure...)

Je vous tiens informés... (hâte d'avoir enfin cette nouvelle version sous la main!)
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Pas d'option pour installer 2.00+ sur MS-SQL?! 10 Monate 4 Wochen her #96283

  • mas_carpone
  • mas_carpones Avatar
  • OFFLINE
  • Expert Lime
  • Beiträge: 86
  • Dank erhalten: 4
  • Karma: 0
Le module est installé visiblement... :(
D'autres idées?
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Pas d'option pour installer 2.00+ sur MS-SQL?! 10 Monate 4 Wochen her #96284

  • DenisChenu
  • DenisChenus Avatar
  • OFFLINE
  • Moderator Lime
  • Beiträge: 5854
  • Dank erhalten: 716
  • Karma: 222
Salut,

Plus précisément: ce sont les modules PDO qui sont utilisés, puis passé par : www.yiiframework.com/doc/api/1.1/CDbConn...ilableDrivers-detail

Les possibilités sont:
public $db_names = array(
	'mysql' => 'MySQL',
	'mysqli' => 'MySQL (newer driver)',
	'sqlsrv' => 'Microsoft SQL Server (sqlsrv)',
	'mssql' => 'Microsoft SQL Server (mssql)',
	'pgsql' => 'PostgreSQL',
	);
Letzte Änderung: 10 Monate 4 Wochen her von DenisChenu.
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Pas d'option pour installer 2.00+ sur MS-SQL?! 10 Monate 4 Wochen her #96286

  • mas_carpone
  • mas_carpones Avatar
  • OFFLINE
  • Expert Lime
  • Beiträge: 86
  • Dank erhalten: 4
  • Karma: 0
J'ai transmis, mais visiblement le problème ne viendrait pas de là? Mon problème c'est que ca dépasse mon domaine de compétences.

L'install est repoussé à la semaine prochaine ( :pinch: )...

Qu'est-ce que je peux faire en attendant pour faire avancer les choses? Quelqu'un d'autre a eu ce genre de "problèmes"?



(NB: dans son dernier message mon collègue mentionne aussi ca: J’ai essaye sur l’autre serveur et cette version ne fonctionne pas non plus pour d’autres raisons qui impliquent de recompiler PHP - ?)
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Pas d'option pour installer 2.00+ sur MS-SQL?! 10 Monate 4 Wochen her #96287

  • DenisChenu
  • DenisChenus Avatar
  • OFFLINE
  • Moderator Lime
  • Beiträge: 5854
  • Dank erhalten: 716
  • Karma: 222
C'est bien en PDO ?

Ton gestionnaire peut il :
1 : créer un fichier phpinfo
2: donner la liste exacte des PDO supportés.

Chez moi cela donne:
PDO
PDO support enabled
PDO drivers mysql, odbc, pgsql, sqlite, sqlite2
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Pas d'option pour installer 2.00+ sur MS-SQL?! 10 Monate 4 Wochen her #96288

  • DenisChenu
  • DenisChenus Avatar
  • OFFLINE
  • Moderator Lime
  • Beiträge: 5854
  • Dank erhalten: 716
  • Karma: 222
Salut,

Peut être avaons nous fait une erreur dans le nom des PDO, par exemple mysqli n'existe pas en pdo.

Donc donne moi la liste (cf ci dessous).

PS: LS s'installe vraiment sur pas mal de serveur, même sur des serveurs free. Devoir recompiler apache implique que le serveur possède vraiment peu d'options. Et puis, de mon coté je n'ai jamais (pour mes serveurs perso) recompilé apache : aptitude install le fait pour moi ....
Letzte Änderung: 10 Monate 4 Wochen her von DenisChenu.
Der Administrator hat öffentliche Schreibrechte deaktiviert.
Folgende Benutzer bedankten sich: mas_carpone

Pas d'option pour installer 2.00+ sur MS-SQL?! 10 Monate 4 Wochen her #96289

  • mas_carpone
  • mas_carpones Avatar
  • OFFLINE
  • Expert Lime
  • Beiträge: 86
  • Dank erhalten: 4
  • Karma: 0
Merci Denis! Je transfert tes infos/suggestions comme elles viennent en espérant de trouver la faille...
Der Administrator hat öffentliche Schreibrechte deaktiviert.

Pas d'option pour installer 2.00+ sur MS-SQL?! 10 Monate 2 Wochen her #96652

  • mas_carpone
  • mas_carpones Avatar
  • OFFLINE
  • Expert Lime
  • Beiträge: 86
  • Dank erhalten: 4
  • Karma: 0
Olé! J'ai enfin réussi à récupérer les infos... ( :side: ). Voilà:

mssql
MSSQL Support enabled
Active Persistent Links 0
Active Links 0
Library version FreeTDS

Directive Local Value Master Value
mssql.allow_persistent On On
mssql.batchsize 0 0
mssql.charset no value no value
mssql.compatability_mode Off Off
mssql.connect_timeout 5 5
mssql.datetimeconvert On On
mssql.max_links Unlimited Unlimited
mssql.max_persistent Unlimited Unlimited
mssql.max_procs Unlimited Unlimited
mssql.min_error_severity 10 10
mssql.min_message_severity 10 10
mssql.secure_connection Off Off
mssql.textlimit Server default Server default
mssql.textsize Server default Server default
mssql.timeout 60 60


PDO support enabled
PDO drivers dblib, mysql, sqlite

pdo_dblib
PDO Driver for FreeTDS/Sybase DB-lib enabled
Flavour freetds

pdo_mysql
PDO Driver for MySQL enabled
Client API version mysqlnd 5.0.10 - 20111026 - $Id: b0b3b15c693b7f6aeb3aa66b646fee339f175e39 $

Directive Local Value Master Value
pdo_mysql.default_socket /tmp/mysql.sock /tmp/mysql.sock

pdo_sqlite
PDO Driver for SQLite 3.x enabled
SQLite Library 3.7.7.1
Der Administrator hat öffentliche Schreibrechte deaktiviert.
  • Seite:
  • 1
  • 2
Moderatoren: Nickko
Ladezeit der Seite: 0.202 Sekunden
Donation Image