Update error: This script can only be run on PHP version 5.3.0 or later!

Mehr
3 Jahre 1 Monat her #109709 von Miguli01
Miguli01 erstellte das Thema Update error: This script can only be run on PHP version 5.3.0 or later!
Hey everyone

I recently tried to update my limesurvey version to 2.05. Since then, I can't login anymore, I just see a blank page with this error on it:

This script can only be run on PHP version 5.3.0 or later! Your version: 5.2.17.

I don't understand what this means and what I have to do now.

I would be extremely thankful if someone could help me.

Thanks in advance,
Best regards,
Michael

P.S. Please use simple, step-by-step explanations because I am not much of an expert. :huh:

Bitte Anmelden um der Konversation beizutretten.

Mehr
3 Jahre 1 Monat her #109723 von holch
holch antwortete auf das Thema: Update error: This script can only be run on PHP version 5.3.0 or later!
It is quite simple. You need to upgrade your server to PHP 5.3 or higher. Your version is 5.2, thus lower than the requested version.

I assume that you will have to get in touch with your host.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Bitte Anmelden um der Konversation beizutretten.

Mehr
3 Jahre 1 Monat her #109747 von Miguli01
Miguli01 antwortete auf das Thema: Update error: This script can only be run on PHP version 5.3.0 or later!
Thanks for your response Holch.

I asked my host (switchplus) how to upgrade and it really seems quite simple.

However, after changing my version to PHP 5.3, I only see a blank page when loading Limesurvey. Not even the error message appears anymore.
Maybe there is some kind of delay until the changes are effective?

Or maybe I chose the wrong edition. There are different PHP editions to upgrade to
1. 5-53Stable
2. 5-53Latest
3. 5-54Stable
4. %-54Latest

And there are also different PHP version to choose from:
1. Extended
2. Light
3. Standard
4. Fast

Of course I tried different combinations of PHP versions and editions. But no combinations worked. I always just see the blank screen when trying to load the login page.

Any ideas?

Bitte Anmelden um der Konversation beizutretten.

Mehr
3 Jahre 1 Monat her #109754 von holch
holch antwortete auf das Thema: Update error: This script can only be run on PHP version 5.3.0 or later!
Generally the blank screen was problem of not having PHP 5.3. I assume that you chose the stable releases. So this should not be a problem.

Sometimes it helps to empty the cache.

And please also have a search for "blank page", "white page" in the forum. I remember quite a few solutions to this problem.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Bitte Anmelden um der Konversation beizutretten.

Mehr
3 Jahre 1 Monat her #109755 von Miguli01
Miguli01 antwortete auf das Thema: Update error: This script can only be run on PHP version 5.3.0 or later!
Emptying the chache didn't solve it.

I will try to search for the key words in the forum, thanks.

By now, I am wondering if it would'nt be easier just to downgrade my limesurvey again. I was visiting the "old versions" page. But I couldn't find out which was the second last version. Could you help me here?

Bitte Anmelden um der Konversation beizutretten.

Mehr
3 Jahre 1 Monat her #109851 von DenisChenu
DenisChenu antwortete auf das Thema: Update error: This script can only be run on PHP version 5.3.0 or later!
Hi,

Can you go to application/config/config.php and set debug to 2 .

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Bitte Anmelden um der Konversation beizutretten.

Mehr
3 Jahre 1 Monat her #109929 von Miguli01
Miguli01 antwortete auf das Thema: Update error: This script can only be run on PHP version 5.3.0 or later!
Hi Denis

Sorry for the basic question, but where do I have to go to applications etc.?

Do you mean in Limesurvey? I cant login to Limesurvey.

Thanks for your help
Michael

Bitte Anmelden um der Konversation beizutretten.

Haben Sie schon bei unserer Kundenumfrage mitgemacht?

Verpassen Sie nicht Ihre Chance auf tolle Preise.

Klicken sie hier um teilzunehmen:

Jetzt starten

Jetzt loslegen!

Melden Sie sich jetzt an, und erstellen Sie in wenigen Minuten Ihre erste Umfrage.

Account einrichten