auth_webserver, and setting information in config.php

Mehr
4 Jahre 3 Monate her #100048 von ColinFine
ColinFine erstellte das Thema auth_webserver, and setting information in config.php
Having created a survey on my local machine, I'm trying to set up limesurvey on the real server.

I'm putting the admin access inside directory which is already authenticated by the webserver.

So I tried setting auth_webserver.

First problem: the manual page (optional settings) says "If you want to change these settings please do not change it in config-defaults.php but copy the particular setting/line over to /application/config/config.php in 'config'=>array() and change it there."

But config.php and config-defaults.php HAVE ENTIRELY DIFFERENT STRUCTURE. config.php is a single expression "return array( .... );" whereas config-defaults.php is all in terms of "$config = somevalue".

I am guessing that when config-defaults.php says
$config = false;

that has to translate into config.php as

return array(
...
'config' => array(
...

'auth_webserver' => true,



because I can't see any other way to get the settings in there. It would be nice, and helpful if something, somewhere, actually explained this - or explained why I am wrong and how you're supposed to do it.

Anyway, having done this, I fire up limesurvey/admin/index.php, having created myself as a user (since I've given up trying to get the autocreate_usar to work. The browser asks me to authenticate, since I've put the url somewhere that does; but limesurvey still expects me to login, contrary to what it says on the "Optional settings" page.

What am I doing wrong, please?

I appear to have 2.00+, build 130802.

Bitte Anmelden um an der Konversation teilzunehmen.

Jetzt loslegen!

Melden Sie sich jetzt an, und erstellen Sie in wenigen Minuten Ihre erste Umfrage.

Account einrichten

Abonnieren Sie unseren Newsletter

Abonnieren Sie unseren Newsletter für alle Neuigkeiten rund um LimeSurvey
captcha