welcomeModal is not displayed - possible bug

Mehr
2 Monate 1 Woche her #172269 von roehle
roehle erstellte das Thema welcomeModal is not displayed - possible bug
Hi there,

we noticed that the welcomeModal intended for first time users is not being displayed (\application\views\admin\super\welcome.php) in our upgraded installation (3.14.2+180807).
Diggin into it we came to the following:
If it is displayed depends on
if($countSurveyList==0  && Permission::model()->hasGlobalPermission('surveys','create')
If you check the definition of the variable $countSurveyList you find that in \application\controllers\admin\index.php
it is defined as
$aData['countSurveyList'] = Survey::model()->count();
(counting all surveys of the installation) whereas it used to be
$aData['countSurveyList'] = count(getSurveyList(true));
(all surveys owned by currently logged in user) which still works if it is changed back to that.
Is this a bug or are we missing something? It does not make sense to use the number of all available surveys here, right?

Stefan

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Monate 1 Woche her #172276 von tpartner
tpartner antwortete auf das Thema: welcomeModal is not displayed - possible bug
Please file a bug report.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Jetzt loslegen!

Melden Sie sich jetzt an, und erstellen Sie in wenigen Minuten Ihre erste Umfrage.

Account einrichten

Abonnieren Sie unseren Newsletter

Abonnieren Sie unseren Newsletter für alle Neuigkeiten rund um LimeSurvey
captcha