Custom Limesurvey Themes 2.05+ don't work with Version 2.50+?

Mehr
2 Jahre 5 Monate her #130842 von sternDesSuedens
sternDesSuedens erstellte das Thema Custom Limesurvey Themes 2.05+ don't work with Version 2.50+?
Hey there,
We made a fresh installation, using the stable Version 2.50+ Build 160204. Now I want to use themes we customized for 2.05+ Build 150520.
When I import them, no error message appears, but the imported themes can not be assigned with a survey. In theme-editor is no text shown inside the code-window, the preview at the bottom of the page shows the default theme, even though i selected one of the freshly imported ones. This also happens with stock 2.05 themes like 'citronade'.

Is there no compatibility between those different theme versions? Why is no error shown? What might be a possible solution?

Thanks for your advice
sternDesSuedens

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Jahre 5 Monate her #130849 von holch
holch antwortete auf das Thema: Custom Limesurvey Themes 2.05+ don't work with Version 2.50+?
Yes, there seems to be a clear cut to the previous versions of Limesurvey.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Jahre 5 Monate her #130853 von sternDesSuedens
sternDesSuedens antwortete auf das Thema: Custom Limesurvey Themes 2.05+ don't work with Version 2.50+?
Well, i can't find any information about this incompatibilty in the update informations ( manual.limesurvey.org/Upgrading_from_a_p...ion#Before_you_start ...), neither did limesurvey itself throw any errors when importing the old themes.

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Jahre 5 Monate her #130861 von Ben_V
Ben_V antwortete auf das Thema: Custom Limesurvey Themes 2.05+ don't work with Version 2.50+?
@sternDesSuedens just open the default template of a new and previous LS release and compare contents... There are some important changes (e.g. all pstpl files are now located in a subfolder)

Check the forum next week for some relevant infos about this new version

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Jahre 5 Monate her #130872 von nwinter
nwinter antwortete auf das Thema: Custom Limesurvey Themes 2.05+ don't work with Version 2.50+?
Is the new template format/syntax/etc. documented somewhere?

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Jahre 5 Monate her #130875 von Ben_V
Ben_V antwortete auf das Thema: Custom Limesurvey Themes 2.05+ don't work with Version 2.50+?
As far as I know... NO

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Jahre 5 Monate her #130877 von holch
holch antwortete auf das Thema: Custom Limesurvey Themes 2.05+ don't work with Version 2.50+?
I don't like how this new release is handled. I am all for clean cuts. After a few years, this is sometimes necessary, even if some people don't like it. But it needs to be communicated. You can't just throw out a release, even pushing it via the ComfortUpdate and leave people in the "rain" with it.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Folgende Benutzer bedankten sich: Ben_V

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Jahre 5 Monate her - 2 Jahre 5 Monate her #130878 von holch
holch antwortete auf das Thema: Custom Limesurvey Themes 2.05+ don't work with Version 2.50+?
And the worst part: Even people who regularily help out on the forum are not informed. So we also can't help.

At the moment we are just flying blind. I guess I take a few weeks off from the forum support and see what happens... ;-)

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Letzte Änderung: 2 Jahre 5 Monate her von holch.

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Jahre 5 Monate her - 2 Jahre 5 Monate her #130879 von LouisGac
LouisGac antwortete auf das Thema: Custom Limesurvey Themes 2.05+ don't work with Version 2.50+?
Hi,

It should be possible to adapt old survey template with the new system without too much difficulties.
We're working on it for the future.

Here basically the work that must be done (you can help with it) :

1. All the question types, less arrays, have now separated views :
github.com/LimeSurvey/LimeSurvey/tree/ma...ews/survey/questions

In a close future, this will give the possibility to any LimeSurvey user with some skill in PHP/JS/CSS to add new question rendering, with its own HTML, JS files, and CSS, and to share them as question modules.

Have a look to the YES/NO question or GENDER question and their new question attribute to see how it works. Basically, for gender question, you can see that we added new 'button' views :
github.com/LimeSurvey/LimeSurvey/tree/ma...vey/questions/gender


accessible via the 'display' question attribute.



2. So, we must finish to export the array question HTML to view

3. Then we must add the old question HTML of 2.0x as views accessible via a display option


For now, I will advise you just to build new template on the base of one of the new ones. They use Bootstrap (easy to use), and are fully responsive.
Letzte Änderung: 2 Jahre 5 Monate her von LouisGac.
Folgende Benutzer bedankten sich: holch, Ben_V

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Jahre 5 Monate her - 2 Jahre 5 Monate her #130880 von LouisGac
LouisGac antwortete auf das Thema: Custom Limesurvey Themes 2.05+ don't work with Version 2.50+?
by the way, the new release is not pushed via comfortUpdate. We don't want to push old LimeSurvey users to move from 2.06 to 2.5 for now.

2.5 is available as a release for new users. So you can just stay with 2.06 to avoid any conversion problem.
Letzte Änderung: 2 Jahre 5 Monate her von LouisGac.

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Jahre 5 Monate her - 2 Jahre 5 Monate her #130883 von LouisGac
LouisGac antwortete auf das Thema: Custom Limesurvey Themes 2.05+ don't work with Version 2.50+?
Also, sorry for the lack of communication about the new release of 2.5.

We're deeply into correcting the last bugs (no critical ones), bugs that have been reported thanks to this release.

Once this is done, and before we offer 2.5 update via comfortUpdate, I'll write a full article about it.

I'll write some tutorials about how to create new templates (with/without bootstrap), how to create question modules (new question rendering for existing question types, with custom HTML, CSS, and JS), and I will update the wiki.
Letzte Änderung: 2 Jahre 5 Monate her von LouisGac.

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Jahre 5 Monate her #130884 von holch
holch antwortete auf das Thema: Custom Limesurvey Themes 2.05+ don't work with Version 2.50+?
@Lous: When I say "pushed" with ComfortUpdate I mean it is prominently offered. But I have seen that this is actually wrong.

Still, I am not sure if the way 2.5 is released is not a little problematic, especially as there are some cuts in terms of backwards compatibility.

People are always eager for new releases and sometimes they just go for it without checking it out beforehand. As there isn't really a release information, they are not warned about what will not work with older stuff like the templates.

I will play around with my 2.5 test installation tonight. First thing to get rid of: The huge, totally unnecessary Limesurvey logo on the main page which is taking up a lot of space and leads to the fact that on my notebook screen not everything is displayed. ;-)

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Jahre 5 Monate her #130886 von LouisGac
LouisGac antwortete auf das Thema: Custom Limesurvey Themes 2.05+ don't work with Version 2.50+?
In 2.06 comfortUpdate, we only offer update to unstable 2.5 release candidate. So it's clear that it's not a production update.

The 2.5 release is available only via download and installation. If anyone use it to update its 2.06installation, it means that he has the necessary skill to do it, and so to backup its previous 2.06installation to restore it if necessary...

The admin templates are easy to change. You can even create a new one copying one of them into the right directory (upload...). Then just change the logo file by another one.

2.5 is modular. You'll have much more control on it.

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Jahre 5 Monate her #130887 von wrenchpilot
wrenchpilot antwortete auf das Thema: Custom Limesurvey Themes 2.05+ don't work with Version 2.50+?
:evil: :evil: :evil: :evil: :evil:
This "lack of communication" just completely destroyed my LimeSurvey installation. Regardless of how you think it's supposed to work, 2.5 was pushed out as a stable update. If you're going to start charging for updates, get it right. I'll be spending the next couple of hours fixing this major screw up. Thanks /s

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
2 Jahre 5 Monate her #130889 von holch
holch antwortete auf das Thema: Custom Limesurvey Themes 2.05+ don't work with Version 2.50+?
Yes, which is why I was looking forward to 2.5. It makes a lot of things write. But still, some information on what has changed and what might "break" would be good and we could avoid things like what wrenchpilot is reporting and will now come over us in the next few weaks in the forum. If we would have a post listing what isn't compatible with previous releases the job in the forum would be easy: "You should have read before you install"...

And of course wrenchpilot should have backed his old instalation up and he probably did, but it is still a lot of unnecessary work which we could have avoided with a few words on what can happen when you install 2.5. I never install completely new versions of the old one. I run them in parallel for a while. So I don't have to move surveys, new surveys are built on the new system.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Jetzt loslegen!

Melden Sie sich jetzt an, und erstellen Sie in wenigen Minuten Ihre erste Umfrage.

Account einrichten

Abonnieren Sie unseren Newsletter

Abonnieren Sie unseren Newsletter für alle Neuigkeiten rund um LimeSurvey
captcha