Automatische Mail Weiterleitung der Ergebnisse

Mehr
4 Monate 15 Stunden her #185597 von ConnectingMedia
Hallo liebe Community,


wir haben eine Umfrage zur Auswertung der DSGVO-Compliance erstellt in der wir am ende eine individuelle Einschätzung darbieten.

Nun würden wir gerne diese Einschätzung an die Mail die am Anfang der Umfrage von den Teilnehmern eingegeben werden muss senden.

Hierzu habe ich bereits viel Recherchiert aber bin leider noch zu keinem Funktionierendem Ergebnis gekommen.


Folgende Einstellungen hab ich bereits vorgenommen doch es scheint noch was zu fehlen



Die Umfrage läuft auf unserem Server.


Über Hilfe wären wir sehr dankbar

LG
Anhänge:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

LimeSurvey Partners
Mehr
4 Monate 12 Stunden her - 4 Monate 12 Stunden her #185609 von holch
Leider beschreibst du ja nicht, was dein eigentliches Problem ist.

Hierzu habe ich bereits viel Recherchiert aber bin leider noch zu keinem Funktionierendem Ergebnis gekommen.

Das ist leider wenig hilfreich, weil es weder erwähnt was du genau schon versucht hast noch was das Ergebnis war.

Ich gehe jetzt mal davon aus, dass das Problem ist, dass keine Email verschickt wird?

Ich sehe hier zwei eventuelle Problem-Punkte:
- Email-Einstellungen: werden denn überhaupt emails verschickt? ich weiss, dass Microsofts Office 365 da wohl gerne mal ein bisschen Probleme macht, was SMTP angeht. Also, testen ob überhaupt Emails verschickt werden. Idealerweise mal deine Email-Adresse eingeben und keinen EM code und schauen was passiert.
-EM-Code falsch: Der Code {email_S001_A001} sieht für mich für eine einfache Email-Abfrage komisch aus.

Kannst du mal zeigen, wie die Frage "email" aussieht? Ich vermute mal, sie ist eine einfache Textabfrage, so wie du das aber ansprichst müsste es eine das eine "Matrix - Text'-Frage sein, was in diesem Fall für mich überhaupt keinen Sinn ergibt, diesen Fragentyp einzusetzen, es sei denn man möchte viele verschiedene Emails abfragen.

Falls es eine einfache Text-Frage ist, sollte {email} die richtige Art sein, die Antwort auf diese Frage anzusprechen.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Letzte Änderung: 4 Monate 12 Stunden her von holch.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Monate 4 Wochen her #185639 von ConnectingMedia
Hallo vielen Dank für die Antwort.

Tut mir leid ich war anscheinend nicht deutlich genug,
es geht darum das überhaupt keine Mails versendet werden, auch nicht wenn ich statt dem EM-Code meine Email-Adresse eingebe.

Bisher habe ich bei "E-Mail Einstellungen" die verschiedenen Methoden "PHP, SMTP, Sendmail, qmail",
und wie gesagt verschiedene Email-Adressen sowie EM-Codes als Empfänger ausprobiert.

Ein Ergebnis hatte ich bisher noch nicht da keine Bestätigungsmails ankommen weder Normale- noch Ausführliche-Bestätigungsmails.


Die Frage ist eine "mehrfache kurze text Auswahl" und es wird lediglich eine Mail benötigt um dahin die Ergebnisse zu senden.

Hier die Frage "email"








Lg
Anhänge:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Monate 4 Wochen her - 3 Monate 4 Wochen her #185640 von jelo

ConnectingMedia schrieb: es geht darum das überhaupt keine Mails versendet werden, auch nicht wenn ich statt dem EM-Code meine Email-Adresse eingebe.

Webmaster der Installation fragen, welche technischen Einschränkungen beim Webserver vorliegen.

Du kannst deine Ausprobiererei auf SMTP limitieren. Alles andere fällt einem heutzutage früher oder später auf die Füsse. Dedizierten E-Mailaccount anlegen, die Zugangsdaten in einem E-Mailclient (z.B. Thunderbird) überprüfen.
Danach die Zugangsdaten und Serverdaten 1:1 in LimeSurvey übertragen. Wenn das dann immer noch nicht klappt, dann kann es z.B. daran liegen, dass der Webserver die Verbindungen standardmäßig blockt. Da muss dann an der Serverkonfiguration geschraubt werden.

Mit LimeSurvey und der Befragung hat das erstmal nichts zu tun.


Ergänzung: Ich hoffe du verwendest nicht deine Office365 Zugangsdaten dort. Die werden unverschlüsselt übertragen. Damit kann jemand dann auf den gesamten Office365-account zugreifen.

Office365:
Host: smtp.office365.com:587
Die TLS Verschlüsslung aktivieren!
Bei Nutzername und bei allen E-Mailadresenfeldern, die mit Absender zutun haben, muss die E-Mailadresse vom genutzten Account rein (also wenn über Diese E-Mail-Adresse ist vor Spambots geschützt! Zur Anzeige muss JavaScript eingeschaltet sein! versendet wird, dann erstmal den SMTP-Benutzernamen auch bei Standard-E-Mailadresse etc verwenden. Sobald das klappt, kann mit abweichenden E-Mails experimentiert werden).

Seit dem 29.5. hat Exchange bei Office365 (Vorfallnummer EX182195) auch das Problem, dass manche E-Mails mit Anhang oder Links nicht angekommen. Das Problem ist noch nicht gelöst. Würde dich aber erst betreffen, wenn du alle anderen Fehler bei den Einstellungen behoben hast.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users
Letzte Änderung: 3 Monate 4 Wochen her von jelo.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Monate 4 Wochen her #185665 von holch
Zu den Email-Problemen hat dir Jelo ja schon was gesagt. Also erstmal testen, was da überhaupt mit dem Email-Versand nicht stimmt.

Aber ich bin immer noch der Überzeugung, dass dein EM-Code einfach nicht stimmt.
Verstehe zwar nicht, warum du für die Abfrage genau einer Angabe (Email-Adresse) eine Frage vom Typ "Mehrfach kurze Texte" verwendest, aber gut, so sei es.
Dann müsste aber der code {email1_SQ001} heissen. Es gibt ja nur Unterfragen und keine Antwortoptionen. Daher würde mit {email1_SQ001_A001} auch keine Email ankommen, abgesehen von den generellen Problemen mit deinem Email-Account.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Monate 3 Wochen her #185779 von ConnectingMedia
Hallo,

vielen dank für die Antworten.

Tut mir leid für die späte Rückmeldung bin leider bisher noch nicht zum Antworten gekommen.


@jelo Danke die Mails kommen nun durch, es gab Differenzen zwischen dem Nutzernamen und den Absender-Adressen. Allerdings bekomme ich nur die Normalen und Ausführlichen Admin Benachrichtigungen jedoch keine Bestätigungsmails, auch nicht wenn ich andere Mails in die umfrage eintrage, woran könnte das liegen?


@holch Der EM-Code funktioniert nun auch Danke. Was wäre den die bessere variante die E-Mail abzufragen? Wenn ich nur "kurzer freier text" auswähle passt das vom Format her nicht mehr zu der Namens-Abfrage (siehe Screenshot) ebenso auch bei einer Matrix-Frage. Wenn ich die E-Mail-Abfrage zur Namens-Abfrage hinzufüge kann ich wiederum keine Validierung speziell für das E-Mail Feld einfügen oder etwa doch ?





Vielen dank und beste Grüße
Anhänge:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Monate 3 Wochen her #185788 von jelo

ConnectingMedia schrieb: Allerdings bekomme ich nur die Normalen und Ausführlichen Admin Benachrichtigungen jedoch keine Bestätigungsmails, auch nicht wenn ich andere Mails in die umfrage eintrage, woran könnte das liegen?

Was sind denn Bestätigungsmails?

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Monate 3 Wochen her #185789 von Joffm
Hallo,
ich mische mich einmal ein.

holch sagte ja nur, dass {email_S001_A001} nicht korrekt ist.
Dies wäre evtl. ein Code für ein Array(Texte)

Was wäre den die bessere variante die E-Mail abzufragen?

Eigentlich ist es ja in Ordnung.
Allerdings, wenn Du schon "Mehrfache kurze Texte" als Fragetyp wählst, hättest Du die Angabe der E-Mail gleich mit hineinnehmen können.

Dann würdest Du eben die dritte Teilfrage mit Deiner "Regular Expression" auf Gültigkeit testen.
Und hier ist dann {Q1_SQ003} als EM für die E-Mail zu nehmen.

Es geht auch als "Matrix(Texte)", allerdings m.E. weniger empfehlenswert.

Hier würdest Du die dritte Teilfrage und deren erste Antwort mit Deiner "Regular Expression" auf Gültigkeit testen.
Und hier ist dann {Q2_Y003_X001} als EM für die E-Mail zu nehmen.
(Y-Achse mit "Y001, Y002,..." durchgezählt, X-Achse entsprechend "X001" (es gibt ja nur eine Spalte))

Dies nur noch zur Ergänzung.
Du kannst es also machen, wie es beliebt und am besten in Dein Design und den Work-Flow passt.
Nur müssen dann eben die Zugriffe auf die Variablen richtig sein.

Aber Dein Problem lag ja eigentlich außerhalb des LimeSurvey-Bereiches und hat sich ja auch geklärt.

Viel Erfolg weiterhin
Joffm


Volunteers are not paid.
Not because they are worthless, but because they are priceless
Anhänge:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Jetzt loslegen!

Melden Sie sich jetzt an, und erstellen Sie in wenigen Minuten Ihre erste Umfrage.

Account einrichten

Abonnieren Sie unseren Newsletter

Abonnieren Sie unseren Newsletter für alle Neuigkeiten rund um LimeSurvey
captcha