Matrix-Filter-Einstellung zieht Antworten aus vorheriger Frage nicht

Mehr
1 Jahr 2 Monate her #157862 von christiankramer
christiankramer erstellte das Thema Matrix-Filter-Einstellung zieht Antworten aus vorheriger Frage nicht
Hallo,

irgendwie scheint der Matrix-Filter nicht zu funktionieren:
  1. Ich habe eine Frage KundenbindungInstrum als Mehrfachauswahl definiert und darin eine Reihe von Antworten angelegt.
  2. Ich habe eine Frage KundenbindungTop als Liste angelegt und als Matrix-Filter "KundenbindungInstrum " gesetzt.
Dennoch erscheint nur eine leere Antwortoption (die standardmäßig bei einer Liste vorhanden ist).

Die Logik-Prüfung bringt keinen Fehler.
Ich habe in die Demo meinen Entwicklungsstand hochgeladen.
Vielleicht will sich das jemand ansehen.

Woran kann das liegen?

Lieben, herzlichen Dank für einen Tipp,
Christian

PS: Limesurvey Version 2.67.3+170728

Beste Grüße,
Christian

Lime Survey Version 2.72.4+171110

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
1 Jahr 2 Monate her #157884 von jelo
jelo antwortete auf das Thema: Matrix-Filter-Einstellung zieht Antworten aus vorheriger Frage nicht
In der Demoinstallation werden alle Befragungen regelmäßig gelöscht.
Daher solltest Du einfach die relevanten Fragen in eine Datei exportieren und hier als Anhang zur Verfügung gestellt.

Are you a student conducting a survey? If yes, tell me why you use LimeSurvey?
www.limesurvey.org/forum/development/116...y-you-use-limesurvey

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
1 Jahr 2 Monate her #157916 von christiankramer
christiankramer antwortete auf das Thema: Matrix-Filter-Einstellung zieht Antworten aus vorheriger Frage nicht
Mach ich gerne in gezippter Form.

Dateianhang:

Dateiname: limesurvey...ions.zip
Dateigröße:2 KB

Beste Grüße,
Christian

Lime Survey Version 2.72.4+171110
Anhang:

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
1 Jahr 2 Monate her #157926 von jelo
jelo antwortete auf das Thema: Matrix-Filter-Einstellung zieht Antworten aus vorheriger Frage nicht
Meine Formulierung war wohl etwas ungenau. Du kopierst die Befragung, und löschts alles nicht relevante raus. Dann exportierst Du die Datei.

Um etwas filtern zu können, sind die exakt gleichen Antwortoptionen (genauer gesagt die Antwortcodes) auch in der zweiten Frage anzugeben. Die Angabe einer Frage im Matrixfilter kopiert/transferiert keine Antworten in die zweite Fragen. Für das "Sonstiges"-Feld ist der Antwortcode in der zweiten Frage "other". Dann sollte es passen.

Are you a student conducting a survey? If yes, tell me why you use LimeSurvey?
www.limesurvey.org/forum/development/116...y-you-use-limesurvey

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
1 Jahr 2 Monate her #157948 von christiankramer
christiankramer antwortete auf das Thema: Matrix-Filter-Einstellung zieht Antworten aus vorheriger Frage nicht
Hi Jelo,

das hat super geklappt.
Jetzt läuft's - bis auf eine Ausnahmen: Die Eingabe im Feld "Sonstiges".

Die Eingabe aus Frage 1 wird nicht in die Liste von Frage 2 übernommen.
Da du ja als Code "Other" gepostet hast, habe ich den auch als Antwortcode eingesetzt. Nur funzt es nicht.


Danke für einen Tipp.

Beste Grüße,
Christian

Beste Grüße,
Christian

Lime Survey Version 2.72.4+171110
Anhang:

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
1 Jahr 2 Monate her #157949 von jelo
jelo antwortete auf das Thema: Matrix-Filter-Einstellung zieht Antworten aus vorheriger Frage nicht
Da wo A2219 steht, sollte other stehen.
Die Inhalte des Feldes Sonstiges sollte mit Questioncode_other verfügbar sein. Also Unterstrich zwischen Code und other.

Falls es immer noch nicht klappt, bitte Umfrage mit den zwei Fragen anhängen.

Hier auch mal eine Übersicht über die Qcode-Variablen.
manual.limesurvey.org/Expression_Manager#Qcode_Variable_Naming

Are you a student conducting a survey? If yes, tell me why you use LimeSurvey?
www.limesurvey.org/forum/development/116...y-you-use-limesurvey

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
1 Jahr 2 Monate her #157965 von christiankramer
christiankramer antwortete auf das Thema: Matrix-Filter-Einstellung zieht Antworten aus vorheriger Frage nicht
Ich hatte schon beide Varianten probiert.
Jetzt habe ich die Umfrage bis auf die beiden Fragen zusammengestrichen.

Danke für deinen hilfreichen Blick.

Dateianhang:

Dateiname: limesurvey...5593.lss
Dateigröße:32 KB

Beste Grüße,
Christian

Lime Survey Version 2.72.4+171110
Anhang:

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
1 Jahr 2 Monate her #157990 von Joffm
Joffm antwortete auf das Thema: Matrix-Filter-Einstellung zieht Antworten aus vorheriger Frage nicht
Hallo, Christian,
mach bitte in samples keine Cookie-Sperre rein.

Okay, Dein Fehler ist:
In deiner zweiten Frage muss der Code für "Sonstige" {KundenbindInstrum_other} heißen.
Um so etwas herauszubekommen, einfach mal ein paar Daten eingeben und sich anschauen, wie der Ergebnisdatensatz aussieht.

Dann funktioniert es gut, sofern ein "Sonstiges" genannt wurde.
Ansonsten erhälst Du dort ein Radio ohne Text.
Das scheint ein Bug zu sein.

Um es auf die Schnelle zu umgehen, mache die zweite Frage ebenfalls zur Mehrfachnennungsfrage und setze dort die maximale Antwortzahl auf 1.

Joffm


Volunteers are not paid.
Not because they are worthless, but because they are priceless
Anhang:
Folgende Benutzer bedankten sich: christiankramer

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
1 Jahr 2 Monate her - 1 Jahr 2 Monate her #158040 von christiankramer
christiankramer antwortete auf das Thema: Matrix-Filter-Einstellung zieht Antworten aus vorheriger Frage nicht
Hi Joffm,

vielen Dank für den Hinweis, auch mit der Cookie-Sperre.

Ich habe jetzt etwas rumprobiert, weil es bei der Eingabe unter "Code" nicht geklappt hat. Ich habe dann den Platzhalter unter "Teilfrage" eingefügt.

Außerdem habe ich deiner Empfehlung folgend aus der zweiten Frage eine Mehrfachnennungsfrage mit Maximalantwort "1" gemacht.

Das Ergebnis:
  • Die Antwort bei "Sonstige" aus Frage 1 erscheint bei Frage 2 als mögliche Antwort.
  • Eine unbeschriftete Antwortoption erscheint bei Frage 2, wenn kein Text und auch keine Auswahl unter "Sonstiges" in Frage 1 eingetragen wurde.


Das ist für den Antwortenden verwirrend, zumal er nur 1 Antwortmöglichkeit hat, obwohl das Formular eine Mehrfachantwort suggeriert. Auch kann er die unbetitelte Option nicht einordnen, die bei entsprechender Auswahl das Ergebnis beeinflusst.

Hm, welche Möglichkeiten - außer des Debuggins - gibt es noch?

Beste Grüße,
Christian

Lime Survey Version 2.72.4+171110
Letzte Änderung: 1 Jahr 2 Monate her von christiankramer.

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
1 Jahr 2 Monate her #158041 von christiankramer
christiankramer antwortete auf das Thema: Matrix-Filter-Einstellung zieht Antworten aus vorheriger Frage nicht
Hab jetzt wieder Frage 2 in Optionsfrage umgewandelt.
Funktioniert!

Insofern gibt es doch keinen Bug.

Beste Grüße,
Christian

Lime Survey Version 2.72.4+171110

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
1 Jahr 2 Monate her #158044 von Joffm
Joffm antwortete auf das Thema: Matrix-Filter-Einstellung zieht Antworten aus vorheriger Frage nicht
Habe es auch einmal neu angelegt.
Läuft wie es sein soll.

Hm, strange


Volunteers are not paid.
Not because they are worthless, but because they are priceless

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Jetzt loslegen!

Melden Sie sich jetzt an, und erstellen Sie in wenigen Minuten Ihre erste Umfrage.

Account einrichten

Abonnieren Sie unseren Newsletter

Abonnieren Sie unseren Newsletter für alle Neuigkeiten rund um LimeSurvey
captcha