Collèges qui disparaissent quand le vote n'est pas fait en une seule fois

Mehr
7 Monate 3 Wochen her #179865 von Nathanael
Bonjour,

Nous utilisons la version 2 de LimeSurvey depuis plusieurs années.
Dans cette version, nous pré-remplissons une question de nos questionnaires via une variable GET que nous passons dans l'URL du questionnaire.
Ex : &COLLEGE={ATTRIBUTE_1}
Cela fonctionne bien. Cependant dans certains cas, notamment lorsque la personne abandonne le questionnaire et y revient à une date ultérieure en cliquant à nouveau sur le lien présent dans le mail qu'elle a reçu pour répondre au questionnaire, la question n'est plus pré-remplie.

Ce bug est-il connu ?
Est-il corrigé par la version 3 de LimeSurvey ?

Je vous remercie.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

LimeSurvey Partners
Mehr
7 Monate 3 Wochen her #179871 von DenisChenu
Il manque d'information pour te répondre,
En effet : je ne comprend pas pourquoi utiliser les paramètre d'entré si tu as déjà les informations dans les attributs : utilise directement la valeur par défaut.

Sinon, selon le questionnaire : on ne met pas à jour les paramètre d'entrée.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
7 Monate 3 Wochen her #179887 von Nathanael
Bonjour DenisChesnu, et merci pour votre réponse.
En fait, ce paramètre permet de classer les utilisateurs, afin d'opérer une pondération dans les résultats.
Ce paramètre fait partie de la base d'utilisateurs (avec 3 à 6 valeurs possibles), et doit être inclus dans les réponses.
Nous envoyons donc les e-mais d'invitations avec un lien qui est personnalisé selon ce paramètre, et une question non affichée est incluse dans le questionnaire pour recevoir ce paramètre.

Et donc ce lien fonctionne bien la première fois, mais si l'utilisateur abandonne son questionnaire et y reviens plus tard, la variable est perdue.

J'espère avoir été plus clair :)

Je suppose que c'est un problème de redirection, et ma question est donc : ce bug est-il résolu dans la version 3 de LimeSurvey.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
7 Monate 3 Wochen her #179896 von DenisChenu
Mais pourquoi ne pas utiliser directement l'attribut dans le questionnaire ?
Sinon : comment est paramétré le questionnaire en terme de liaison des invitaions et des réponses ?
Il est anonyme ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Moderatoren: Nickko

Jetzt loslegen!

Melden Sie sich jetzt an, und erstellen Sie in wenigen Minuten Ihre erste Umfrage.

Account einrichten

Abonnieren Sie unseren Newsletter

Abonnieren Sie unseren Newsletter für alle Neuigkeiten rund um LimeSurvey
captcha