Problem whit RANK layout

Mehr
5 Jahre 10 Monate her - 5 Jahre 10 Monate her #94066 von nicoillo
COM_KUNENA_MESSAGE_CREATED_NEW
Hi to all, I have a big big problem that I can't fix: the ranking question does not appear correctly with internet explorer, you can see it in the picture.

Probably is a template-related problem, because with default template this does not happen, but I'm not so good with css so, after 5 hours of attempts, I ask you some help.

Where could be the problem?



Here you can try the survey (use explorer before 12 or 11 or development tools in explorer -> browser mode ie7): survey

thank you!
Last edit: 5 Jahre 10 Monate her by nicoillo.

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
5 Jahre 10 Monate her - 5 Jahre 10 Monate her #94077 von nicoillo
COM_KUNENA_MESSAGE_REPLIED_NEW
Please, someone can help me?

Sometimes it happens also with default template! How it's possible?
Last edit: 5 Jahre 10 Monate her by nicoillo.

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
5 Jahre 10 Monate her #94085 von DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW
Hello,
This question his hidden at starting (by condition ) ?
If yes: update to the last version.

Else:
- Did you activate "Same choice for all list" ?

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
5 Jahre 10 Monate her #94087 von nicoillo
COM_KUNENA_MESSAGE_REPLIED_NEW
Hello, and thank you.
No, ther's no condition for this question.
I already have the last version.

"Did you activate "Same choice for all list""
I'm sorry but I don't know what is this, where I can activate it and what is it?

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
5 Jahre 10 Monate her #94090 von DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW
With the last version ranking.css must be added for all template.

Can you show me a survey with a little example of a ranking question ?

Did you have this line in your template startpage.pstpl : {TEMPLATECSS}


For "Same hight for all choice"/"Same hight for list" : look at advanced parameter of the question.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
5 Jahre 10 Monate her - 5 Jahre 10 Monate her #94091 von nicoillo
COM_KUNENA_MESSAGE_REPLIED_NEW
Can you show me a survey with a little example of a ranking question ?: survey

Did you have this line in your template startpage.pstpl : {TEMPLATECSS}? Yes.

"Same hight for all choice"/"Same hight for list" is set to Yes.
Last edit: 5 Jahre 10 Monate her by nicoillo.

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
5 Jahre 10 Monate her - 5 Jahre 10 Monate her #94092 von DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW

nicoillo schrieb: Can you show me a survey with a little example of a ranking question ?: survey
.

This one seems good for me (FF18/chromium/Midori).

Arg. Not IE7, and debugging css with IE7 is a pity ....

Try to copy/paste ranking.css at end of your temlate.css

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last edit: 5 Jahre 10 Monate her by DenisChenu.

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
5 Jahre 10 Monate her #94093 von nicoillo
COM_KUNENA_MESSAGE_REPLIED_NEW
For me too, the problem is only with internet explorer before 12 (or 11).

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
5 Jahre 10 Monate her #94094 von DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW

DenisChenu schrieb: Arg. Not IE7, and debugging css with IE7 is a pity ....

Try to copy/paste ranking.css at end of your temlate.css


And more : With default template it's OK ?

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
5 Jahre 10 Monate her #94095 von nicoillo
COM_KUNENA_MESSAGE_REPLIED_NEW
Whit default template sometimes it's ok, sometime no. :blink:

'Arg. Not IE7, and debugging css with IE7 is a pity ....' I know...it's about 30 hours I'm trying to do it!!!

Now I try to copy ranking.css at the end...


"With the last version ranking.css must be added for all template". What do you mean with this? I have to put rankin.css in my template folder and include it in the html or with {TEMPLATECSS} am I ok?

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
5 Jahre 10 Monate her - 5 Jahre 10 Monate her #94097 von DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW

nicoillo schrieb: Whit default template sometimes it's ok, sometime no. :blink:

? Can you find when it work and when not ?
If you find it : please do a bug report.

nicoillo schrieb: "With the last version ranking.css must be added for all template". What do you mean with this? I have to put rankin.css in my template folder and include it in the html or with {TEMPLATECSS} am I ok?

No, you have it in the survey: this is OK.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last edit: 5 Jahre 10 Monate her by DenisChenu. Begründung: Bad quote

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
5 Jahre 10 Monate her - 5 Jahre 10 Monate her #94099 von nicoillo
COM_KUNENA_MESSAGE_REPLIED_NEW

DenisChenu schrieb: Can you find when it work and when not ?
If you find it : please do a bug report.


With default template, in Internet Explorer 10 with developer tools/browser mode setted on IE7:

in THIS survey I look this:


in THIS survey I see ok:


so, where could be the problem? (besides the fact that explorer is a shame)
Last edit: 5 Jahre 10 Monate her by nicoillo. Begründung: new sentence written

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
5 Jahre 10 Monate her #94103 von DenisChenu
COM_KUNENA_MESSAGE_REPLIED_NEW
The first link is not the ranking question of LS2.0 but a workaround with 1.92.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
5 Jahre 10 Monate her #94105 von tpartner
COM_KUNENA_MESSAGE_REPLIED_NEW
From what I see in your test survey, IE is being forced into compatibility mode.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Mehr
4 Wochen 2 Tage her #179405 von MackFord
COM_KUNENA_MESSAGE_REPLIED_NEW
Please, someone can help me?

I am getting the same problem is only with internet explorer.

Bitte Anmelden oder Registrieren um an der Konversation teilzunehmen.

Jetzt loslegen!

Melden Sie sich jetzt an, und erstellen Sie in wenigen Minuten Ihre erste Umfrage.

Account einrichten

Abonnieren Sie unseren Newsletter

Abonnieren Sie unseren Newsletter für alle Neuigkeiten rund um LimeSurvey
captcha