default template, 2 row multi-choice question and Internet Explorer

Mehr
4 Jahre 2 Wochen her #93310 von pweldon
Hi. I'm using Limesurvey 2.0 - and basing my survey on the 'default' template.

I have a question that uses the 'multiple choice' question type and I have set 'display columns' to 2

Looks fine in Firefox but in IE the boxes are indented and the text is underneath the box.

This doesn't happen with radio buttons when display columns is 2 in IE.

I've attached a screen shot from IE. Anyone know how to resolve this?
Anhang:

Bitte Anmelden um der Konversation beizutretten.

Mehr
4 Jahre 2 Wochen her #93469 von tpartner
What version of IE?

Can you activate a sample survey for us to test?

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Bitte Anmelden um der Konversation beizutretten.

Mehr
4 Jahre 1 Woche her #93566 von pweldon
IE 8.0.6001

here's a sample survey:

sias.acer.edu.au/index.php?r=survey/index/sid/535482/lang/en

Thanks
Paul

Bitte Anmelden um der Konversation beizutretten.

Mehr
4 Jahre 1 Woche her #93658 von tpartner
Unfortunately, I can't see what's causing the misalignment.

This is what I see in IE8 - Win-7:


Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Anhang:

Bitte Anmelden um der Konversation beizutretten.

Mehr
4 Jahre 1 Woche her #93691 von pweldon
I passed this to our IT guys and got this response:

"I think the issue lies in the version of IE8, this is an early build of IE8 which does not seem to support the css style that is being used, while even just later versions of IE8 seem to."

that is, this build of IE 8 is the current latest for XP, Vista, and Windows Server 2008 R2 (see support.microsoft.com/kb/969393 ) - IE 7 and earlier and IE 8 for Win7 etc is fine.

Our guy found a fix that looks like the attachment - if you're interested I can ask him to post it...
Anhang:

Bitte Anmelden um der Konversation beizutretten.

Mehr
4 Jahre 1 Woche her #93709 von DenisChenu

pweldon schrieb: Our guy found a fix that looks like the attachment - if you're interested I can ask him to post it...

Great,

Please fill a bug report with patch.

Denis
PS: Tony: have an XP installation with IEtester (IE6/7/8) i can take the bug.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Bitte Anmelden um der Konversation beizutretten.

Mehr
4 Jahre 5 Tage her #94026 von pweldon
I'll post to the bug tracker, but as the fix is simple I'll put it here too. It seems to affects the latest version of IE for XP (8). The fix is:

The code was:
display: inline-block;
The code I used was a known Internet Explorer hack:
display: inline-block;
display: inline\9;

Internet Explorer will be the only browser that reads that second line which will override the first line. I just replaced all instances where that first line of code exists with the two lines of code, inside the template.css file.

Bitte Anmelden um der Konversation beizutretten.

Mehr
4 Jahre 4 Tage her #94037 von DenisChenu
Hello,

In general i use:
display: inline;display: inline-block;

Navigator who don't understand inline-block don't read second instruction.

Don't know what is the best :)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Bitte Anmelden um der Konversation beizutretten.