ComfortUpdate PHP Error

Mehr
3 Jahre 4 Monate her #141918 von tamase
ComfortUpdate PHP Error wurde erstellt von tamase
Hi!
I am receiving PHP Errors when I want to execute the comfortupdate, I am in Version 2.06+ Build 150731:

Undefined property: stdClass::$title (/var/www/html/application/views/admin/update/updater/welcome/_subscribe.php:7)

#0 /var/www/html/application/views/admin/update/updater/welcome/_subscribe.php(7): LSYii_Application->handleError()
#1 /var/www/html/framework/web/CBaseController.php(126): require()
#2 /var/www/html/framework/web/CBaseController.php(95): AdminController->renderInternal()
#3 /var/www/html/framework/web/CController.php(869): AdminController->renderFile()
#4 /var/www/html/application/controllers/admin/update.php(459): AdminController->renderPartial()
#5 /var/www/html/application/controllers/admin/update.php(99): update->_renderWelcome()
#6 unknown(0): update->getwelcome()
#7 /var/www/html/framework/web/actions/CAction.php(108): ReflectionMethod->invokeArgs()
#8 /var/www/html/application/core/Survey_Common_Action.php(99): update->runWithParamsInternal()
#9 /var/www/html/framework/web/CController.php(308): update->runWithParams()
#10 /var/www/html/framework/web/CController.php(286): AdminController->runAction()
#11 /var/www/html/framework/web/CController.php(265): AdminController->runActionWithFilters()
#12 /var/www/html/application/controllers/AdminController.php(164): AdminController->run()
#13 /var/www/html/framework/web/CWebApplication.php(282): AdminController->run()
#14 /var/www/html/framework/web/CWebApplication.php(141): LSYii_Application->runController()
#15 /var/www/html/framework/base/CApplication.php(184): LSYii_Application->processRequest()
#16 /var/www/html/index.php(211): LSYii_Application->run()

any ideas?
Thanks,
Tom

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

LimeSurvey Partners
Mehr
3 Jahre 4 Monate her #141920 von LouisGac
can you still see the input for the comfortUpdate key? If yes, just enter you comfortUpdate key and do the update.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Jahre 4 Monate her #141921 von tamase
sorry I don´t understand, which input do you mean, and which key? I´ve never done the comfortupdate before...thanks a lot

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Jahre 4 Monate her #141924 von LouisGac

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Jahre 4 Monate her #141926 von LouisGac
About your bug, please, turn off debug mode in config.php to be able to insert your comfortUpdate key.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Jahre 4 Monate her #141927 von tamase
thanks a lot, now I am getting:

To use comfortUpdate for LTS version, you need to subscribe to a Premium Package. Free keys are not accepted.

Sorry, don´t even know what LTS version means :(

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Jahre 4 Monate her #141928 von tamase
okay, now I understand :( so I better leave the comfortupdate...

www.limesurvey.org/blog/69-limesurvey-ne...e-to-subscribers-now

As announced in your previous blog post the 2.06LTS (Long Term Support) version is now available!
Please note that this version is available on ComfortUpdate and release package download only to our Premium Package subscribers.
This LTS version is only meant for existing users of LimeSurvey 2.06 - if you are a new user please download and use the latest Version 2.50 instead.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Jahre 4 Monate her - 3 Jahre 4 Monate her #141930 von LouisGac
LTS version exists for professional users who needs to stay on 2.06 (because of custom templates, custom plugins, custom workarounds, etc).

It cost us time and money to maintain it for professionals, that's why we push them to subscribe (because not so many professional users of LimeSurvey are doing donation). If we have enough donation, comfortUpdate and access to LTS would be free. That's up to the community.

If you're not a professional, and just want to update for free, you can update to 2.5. It's very reliable and stable now.
Letzte Änderung: 3 Jahre 4 Monate her von LouisGac.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Jahre 4 Monate her #141931 von tamase
okay thanks a lot four the excellent explanation

you are right with the update to 2.5 but my collegues are afraid that a lot of things changed in the new version (interface etc.), so we stay with 2.06 for the moment

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Jahre 4 Monate her #141932 von LouisGac
So, you should just subscribe to a package.
Some major security issues have been fixed in 2.06lts.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Jahre 4 Monate her #141933 von tamase
hm okay and how does that work?

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Jahre 4 Monate her #141935 von LouisGac
Well, when subscribing to a package, you'll have a premium key, which allow to update to 2.06lts.
We port to 2.06lts all the security fixes, and the most important bugs found on 2.5 (many bugs found on 2.5 also apply to 2.06).

see: www.limesurvey.org/forum/news/102757-lim...ity-advisory-10-2015

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
3 Jahre 4 Monate her #141936 von tamase
we are on Version 2.06+ Build 150731

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Jetzt loslegen!

Melden Sie sich jetzt an, und erstellen Sie in wenigen Minuten Ihre erste Umfrage.

Account einrichten

Abonnieren Sie unseren Newsletter

Abonnieren Sie unseren Newsletter für alle Neuigkeiten rund um LimeSurvey
captcha