symlink(): Cannot create symlink, error code(1314)

Mehr
2 Jahre 10 Monate her - 2 Jahre 10 Monate her #145459 von JamLizzy101
Hi

I'm trying to install LimeSurvey on Windows hosting, but I have stumbled into the following error for installation:-

Internal Server Error
symlink(): Cannot create symlink, error code(1314)

An internal error occurred while the Web server was processing your request. Please contact the webmaster to report this problem.

Thank you.

It seems permissions based.

There is this function called symlink() in /limesurvey/framework/web/CAssetManager.php on line 243 that seems to be utilizing these folders:-
D:\home\jn-devsite.com\wwwroot\limesurvey\third_party\jquery
D:\home\jn-devsite.com\wwwroot\limesurvey\tmp\assets\bd57646a
D:\home\jn-devsite.com\wwwroot\limesurvey\third_party\jqueryui
D:\home\jn-devsite.com\wwwroot\limesurvey\tmp\assets\bf6dab84
D:\home\jn-devsite.com\wwwroot\limesurvey\third_party\fontawesome
D:\home\jn-devsite.com\wwwroot\limesurvey\tmp\assets\ba340ac4
D:\home\jn-devsite.com\wwwroot\limesurvey\application\extensions\bootstrap
D:\home\jn-devsite.com\wwwroot\limesurvey\tmp\assets\8051338c
D:\home\jn-devsite.com\wwwroot\limesurvey\application\extensions\bootstrap\assets
D:\home\jn-devsite.com\wwwroot\limesurvey\tmp\assets\7559c168


Has anybody encountered this before and does one know how to fix this?
I read up a little on the search engines and they mentioned disabling the LinkAssets option, but am unsure where that is...
Letzte Änderung: 2 Jahre 10 Monate her von JamLizzy101. Begründung: Adding extra info

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

LimeSurvey Partners
Mehr
2 Jahre 10 Monate her #145465 von DenisChenu
? What version did you use ?
Because symling creation was disabled in our stable version (in general).

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
2 Jahre 10 Monate her #145475 von JamLizzy101
Hi

This version is 2.57
I found that the setting for LinkAssets was set to false

I could comment out: symlink($src,$dstDir); on line 243 and it shows the installation, but that's probably going to have dire consequences on this I'm sure...

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
2 Jahre 10 Monate her - 2 Jahre 10 Monate her #145485 von LouisGac
Sorry, on of the dev broke it.

For now, just remove that line (or set it to false):
github.com/LimeSurvey/LimeSurvey/blob/ma..._Application.php#L87

we'll fix it in next release
Letzte Änderung: 2 Jahre 10 Monate her von LouisGac.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
2 Jahre 10 Monate her - 2 Jahre 10 Monate her #145491 von DenisChenu

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .
Letzte Änderung: 2 Jahre 10 Monate her von DenisChenu.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
2 Jahre 10 Monate her - 2 Jahre 10 Monate her #145492 von LouisGac
yes I've seen that. He just commented and uncommented the same line, so he probably thought he inactivate it, but he didn't :silly:
Letzte Änderung: 2 Jahre 10 Monate her von LouisGac.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
2 Jahre 10 Monate her #145493 von DenisChenu
I put the comment : config.php is done for this.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
2 Jahre 10 Monate her - 2 Jahre 10 Monate her #145504 von JamLizzy101
Hi there. You mentioned I should remove a line?
Which line are you referring to?

I also added 'linkAssets'=>false to the following line of code in application\config\internal.php :-

'assetManager' => array(
'excludeFiles' => array("config.xml", "assessment.pstpl", "clearall.pstpl", "completed.pstpl", "endgroup.pstpl", "endpage.pstpl", "groupdescription.pstpl", "load.pstpl", "navigator.pstpl", "printanswers.pstpl", "print_group.pstpl", "print_question.pstpl", "print_survey.pstpl", "privacy.pstpl", "question.pstpl", "register.pstpl", "save.pstpl", "startgroup.pstpl", "startpage.pstpl", "surveylist.pstpl", "survey.pstpl", "welcome.pstpl" ),
'baseUrl' => '/tmp/assets',
'basePath'=> dirname(dirname(dirname(__FILE__))).DIRECTORY_SEPARATOR.'tmp'.DIRECTORY_SEPARATOR.'assets',
),


It didn't work. Should that now be taken out?
Letzte Änderung: 2 Jahre 10 Monate her von JamLizzy101. Begründung: adding extra info

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
2 Jahre 10 Monate her #145505 von LouisGac
yes we update the code, so the link is no more valid.
Remove this line:
github.com/LimeSurvey/LimeSurvey/blob/11..._Application.php#L87
Folgende Benutzer bedankten sich: JamLizzy101

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
2 Jahre 10 Monate her #145508 von JamLizzy101
Ok. That definitely had got it working. I can run through the installation now

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Jetzt loslegen!

Melden Sie sich jetzt an, und erstellen Sie in wenigen Minuten Ihre erste Umfrage.

Account einrichten

Abonnieren Sie unseren Newsletter

Abonnieren Sie unseren Newsletter für alle Neuigkeiten rund um LimeSurvey
captcha