Relevance equation in sub questions not working on some browsers

Mehr
4 Monate 1 Woche her #191607 von lakfel
I could not find an answer in forums.

I am testing a survey where I have filters on subquestions based on attributes values with relevance equations in the subquestion definitions. I seems to work well in Chrome, some Mozilla versions, and Opera. But It does not work on Internet Explorer.

I can not control which browser the user is gonna use. Is this an issue addressed in new releases?

My LS version
Versión 3.14.11

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

LimeSurvey Partners
Mehr
4 Monate 1 Woche her - 4 Monate 1 Woche her #191609 von Joffm
Always the best: Send a sample as lss that we can reproduce it.

Attributes is "token attributes"?


Volunteers are not paid.
Not because they are worthless, but because they are priceless
Letzte Änderung: 4 Monate 1 Woche her von Joffm.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
4 Monate 1 Woche her #191610 von lakfel
Yes Token Attribute.
I just re do a new survey. The attribute 1 is either P1 or P2 and in the only question on the survey, 2 subquestions are for P1 and 2 for P2.

When the borwser is chrome the filters work good as the image shows, but when is I explorer, it filters only one.
Explorer



Chrome

Anhänge:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
4 Monate 1 Woche her #191611 von lakfel
I forgot to say. I did not find anything on change logs

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
4 Monate 1 Woche her #191612 von tpartner
It works as expected for me in IE 9/10/11.

What version of IE are you using?

Do you see any errors in the console?

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Official LimeSurvey Partner - partnersurveys.com

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
4 Monate 1 Woche her #191613 von tpartner
...I suggest updating to the latest LimeSurvey version and retesting.

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.
Official LimeSurvey Partner - partnersurveys.com

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
4 Monate 1 Woche her - 4 Monate 1 Woche her #191614 von lakfel
There are 2 errors on console



IExplorer version > 11.864.17763.0

I noticed that in some Mozilla versions happens too
Anhänge:
Letzte Änderung: 4 Monate 1 Woche her von lakfel.

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
4 Monate 5 Tage her #191685 von lakfel
I updated limesurvey to the last version keeping the database but it is not working either. In Chrome filters are being applied well, but not in Internet explorer

Help :/

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
4 Monate 5 Tage her #191686 von lakfel
I followed the console in Chrome to understan whats happening.


Apprently it is something that happens with IE, as the library checks what browser is being used. I followed that issue on Stackoverflow and indeed appraently IE does not support a"Array.from" function as reported on

stackoverflow.com/questions/36810940/arr...he-internet-explorer

So I tried to solve it adding a definition of the methos but instead, all subquestions are hidden. It seems is only a matter to improve the method. What is interesting is that here was reported to work normally.
Anhänge:

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Mehr
4 Monate 5 Tage her #191693 von DenisChenu
Hi,

If you can reproduce with a sample light survey and core theme on 3.20.X : best is to report the issue on our Bugtracker.

And see what happen with different settings on logging (GUI part) and debug (php part).

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand , plugin development .
An error happen ? Before make a new topic : remind the Debug mode .

Bitte Anmelden oder Registrieren um der Konversation beizutreten.

Jetzt loslegen!

Melden Sie sich jetzt an, und erstellen Sie in wenigen Minuten Ihre erste Umfrage.

Account einrichten

Abonnieren Sie unseren Newsletter

Abonnieren Sie unseren Newsletter für alle Neuigkeiten rund um LimeSurvey
captcha