Sortie de LimeSurvey 2.05...

More
3 years 2 months ago #103623 by c_schmitz

La plupart d'entre vous ont pu remarquer la sortie des version 2.05+ récemment. LimeSurvey 2.05 apporte un pas en avant sur les possibilités d'extensions de LimeSurvey, et d'étendre LimeSurvey avec vos propres fonctions. Le concept des extensions pour LimeSUrvey est encore jeune et certaines fonctions manquent encore mais nous comptons sur n’importe quelle contribution de la communauté qui pourront nous aider à étendre les fonctions actuelles.

La nouvelle version pose de nouvelles limites sur les codes des question, ceci pour assurer l'intégrité et préparer les grands changements à venir pour les versions 2.1 et 2.2. Merci de noter que la version 2.05 + n'est pas encore disponible sur la mise à jour confort. Il nous reste à aplanir les quelques problèmes de mise à niveau mineures. Cette version sera automatiquement disponible une fois que nous serons certains que le système de mise à jour fonctionne bien. Les conseils et aide (rapports de bugs) sont toujours les bienvenus!


Best regards

Carsten Schmitz
LimeSurvey project leader

Please Log in to join the conversation.

More
3 years 2 months ago #103769 by DenisChenu
HI,
Good link for read more: / Bon lien pour la suite
www.limesurvey.org/fr/component/content/...e-de-limesurvey-2-05

;)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).

Please Log in to join the conversation.

More
2 years 10 months ago #109112 by zoulou
Hi

Only problem is that this version also is vulnerable .

Only two weeks after lime survey 2.05 was installed on our server, it was attacked and as a result shutdown for three days.
The administrator of the server says that a tool like Zed Attack Proxy reveals such vulnerabilities inside lime survey. How is it that a new version is released without performing these basic security tests ?

No need to say that the software has been removed from the site and I will recommand to everybody I know not to use it.

Regards
Zoulou

Please Log in to join the conversation.

More
2 years 10 months ago #109113 by holch
Did you create a bug report and report back such a vulnerability? This is a community project and everyone can help to make it better. For example the server administrator could help to run such tests and help to make Limesurvey better and more secure.

Most attacks that I have seen so far resulted to be a hack of the server itself and not Limesurvey (not saying that this couldn't be the case).

And I haven't read of any other attacked LS installation lately here in the forum. So it would be great if the server admin could share his information that reveals the vulnerabilities, so that the developers can check this and fix it, if it is a vulnerability within Limesurvey.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
The following user(s) said Thank You: DenisChenu, Ben_V

Please Log in to join the conversation.