KCFinder Image Browse Server not working

More
2 months 4 weeks ago #157957 by tammo
tammo replied the topic: KCFinder Image Browse Server not working
Debug=1 now, cannot login anymore:

PHP warning

array_merge(): Argument #2 is not an array

/home/admin/domains/vragenlijst.toolsforresearch.com/public_html/application/helpers/common_helper.php(203)

191 $timeadjust = getGlobalSetting('timeadjust');
192 App()->setLanguage((isset(Yii::app()->session) ? Yii::app()->session : 'en'));
193
194 if(is_null($cached)) {
195 $surveyidresult = Survey::model()
196 ->permission(Yii::app()->user->getId())
197 ->with('defaultlanguage')
198 ->findAll(array('order'=>'surveyls_title'));
199
200 $surveynames = array();
201 foreach ($surveyidresult as $result)
202 {
203 $surveynames[] = array_merge($result->attributes, $result->defaultlanguage->attributes);
204 }
205
206 $cached = $surveynames;
207 } else {
208 $surveynames = $cached;
209 }
210 $surveyselecter = "";
211 if ($returnarray===true) return $surveynames;
212 $activesurveys='';
213 $inactivesurveys='';
214 $expiredsurveys='';
215 if ($surveynames)

>>> Perhaps stupid question: where do I find session cookies? What should I look for?


Tammo ter Hark at Tools for Research
Proud developers of the TFR Responsive Limesurvey template
toolsforresearch.com/limesurvey-responsive-template

Please Log in to join the conversation.

More
2 months 4 weeks ago #157958 by tammo
tammo replied the topic: KCFinder Image Browse Server not working
And the error message disappears when I put debug = 0 again.

Tammo


Tammo ter Hark at Tools for Research
Proud developers of the TFR Responsive Limesurvey template
toolsforresearch.com/limesurvey-responsive-template

Please Log in to join the conversation.

More
2 months 4 weeks ago #157959 by tammo
tammo replied the topic: KCFinder Image Browse Server not working
So with debug = 0, I can login again, but still the KCFinder does not work...


Tammo ter Hark at Tools for Research
Proud developers of the TFR Responsive Limesurvey template
toolsforresearch.com/limesurvey-responsive-template

Please Log in to join the conversation.

More
2 months 4 weeks ago #157966 by DenisChenu
DenisChenu replied the topic: KCFinder Image Browse Server not working
You have a survey without survey_language.

I think we already fix it ???? But seems not in 2.6lts : github.com/SondagesPro/LimeSurvey-Sondag...mmon_helper.php#L203

You can fix it finding the broken survey in DB … (or adding something like if(empty($result->attributes) || empty($result->defaultlanguage->attributes){ tracevar($result) } else {//current code (line broken) } )

About session cookies information : Firefox F12

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Attachments:

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!