Problem with upgrade from 1.92 to 2.05

More
3 years 4 weeks ago #109355 by wrkilu
wrkilu created the topic: Problem with upgrade from 1.92 to 2.05
Hi,

I did upgrade with your tutorial manual.limesurvey.org/Upgrading_from_a_previous_version and unfortunately I get SQL error during entry trying. It says: CDbCommand failed to execute the SQL statement: SQLSTATE[42S22]: Column not found: 1054 Unknown column 't.allowjumps' in 'field list'.

What should I do with this ?

Thanks for help.

Please Log in to join the conversation.

More
3 years 4 weeks ago #109357 by c_schmitz
c_schmitz replied the topic: Problem with upgrade from 1.92 to 2.05
Restore the database from the backup you took before upgrading - then try again. See if you get a different message.

Best regards

Carsten Schmitz
LimeSurvey project leader

Please Log in to join the conversation.

More
3 years 3 weeks ago - 3 years 3 weeks ago #109379 by wrkilu
wrkilu replied the topic: Problem with upgrade from 1.92 to 2.05
I've restored Mysql (old good) from backup and now in webbrowser is error:
CDbCommand failed to execute the SQL statement: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'languagesettings.surveyls_attributecaptions' in 'field list'

I must to add that during upgrading there is an info/site that application is still upgrading and "please for patience". And this info appears long and long and never end..

What now ?
Last Edit: 3 years 3 weeks ago by wrkilu.

Please Log in to join the conversation.

More
3 years 3 weeks ago - 3 years 3 weeks ago #109560 by wrkilu
wrkilu replied the topic: Problem with upgrade from 1.92 to 2.05
We've waited longer and after couple of hours the problem on main page was missing, we've got list of surveys but..
- on page with upgrading still is statement: "database is upgrading, please be patient"
- on admin page there is a page with "upgrade database, type of database, name of database, table prefix and so on, and click to continue"
After 24 hours nothings change. So we had to back for old version because of no ability to log in.

What do you think about that ? What we can do with this ?

As you see 2.0 version is very important for us.
Last Edit: 3 years 3 weeks ago by wrkilu.

Please Log in to join the conversation.

More
2 years 11 months ago #110897 by blazko
blazko replied the topic: Problem with upgrade from 1.92 to 2.05
Do you solve it?
Im having the same issue with it right now.

THe please be patient message is taking forever :(

Please Log in to join the conversation.

More
2 years 11 months ago #111092 by wrkilu
wrkilu replied the topic: Problem with upgrade from 1.92 to 2.05
I took the newest version and tried once again strictly with upgrade tutorial and it works!

Notice: don't bother with this "please be patient" page. I mean.. don't close it because upgrade still is being, so wait couple of hours even, and then you should be able to login to new version ,and upgrade then is done.

Regards.

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now