White screen during Comfort Update

More
3 years 4 months ago #104248 by DenisChenu
DenisChenu replied the topic: [SOLVED] White screen / HTTP 500 error during Comfort Update
Maybe confortupdate don't get the good file here.

In this file i have : $settings = SettingGlobal::model()->findAll();

Don't really know ???

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in to join the conversation.

More
3 years 4 months ago #104253 by holch
holch replied the topic: [SOLVED] White screen / HTTP 500 error during Comfort Update
Problem seems to be solved. Here is what I did:

Thanks to Denis' comment I activated the debug mode with the following command added to the index.php:
error_reporting(E_ERROR | E_PARSE);

Then I received the following error message:
Fatal error: Class 'Settings_global' not found in /home/pdb/public_html/surveys/sc3/application/helpers/globalsettings_helper.php on line 22

So I did uploaded globalsettings_helper.php again, which did not help.

Then I uploaded everything from the latest version of LS 2.0 available in the download section, which is not the newest one I guess (limesurvey200plus-build131206.tar.gz).

This seems to have done the trick. So now I have the version Version 2.00+ Build 131206, but there is no update available.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now