What is the newest limesurvey I can run using mysql v5.1.73 and php v5.3.3?

More
2 weeks 2 days ago #182892 by djbthesecond
Howdy,

Because reasons, my LAMP stack included mysql v5.1.73 and php v5.3.3 and I'm running limesurvey v2.06

I had a look at the site www.limesurvey.org/downloads/category/24-archived-releases but I don't see details about the minimum version specs for each release.

Could someone please recommend a version that I can safely upgrade to given the limitations above?

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
2 weeks 2 days ago #182939 by holch
I think you should think about updating/upgrading your LAMP stack as well. PHP 5.3.3 is EOL for a while now and your server is potentially vulnerable.
www.php.net/eol.php

For the 5.3 branch end of life was 14 Aug 2014, so 4 years and 7 months ago! And you don't even have updated to the latest version of this branch (5.3.29).

Your MySQL version is even older: 5.1 EOL date: 2013-12-31.

So please update your LAMP stack to recent versions.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
The following user(s) said Thank You: cdorin

Please Log in or Create an account to join the conversation.

More
1 week 5 days ago #183140 by djbthesecond
Sorry, I should have stated that my hands are tied as far as mysql and php versions are concerned.

Can anyone recommend a most recent version of limesurvey that will run in this environment?

Please Log in or Create an account to join the conversation.

More
1 week 4 days ago - 1 week 4 days ago #183177 by holch
Sorry if this might sound harsh, but I think it needs to be said:

No, I can not recommend to run ANYTHING in this environment. This environment is potentially dangerous and I can not recommend to run any web application in this environment, let alone an application like Limesurvey that collects (personal) data from respondents. You have a responsibility for the collected data and your respondents expect you to handle their data with the utmost confidenciality and data safety, which with such an outdated is not possible to guarantee.

In times of GDPR (even if outside of Europe it will get you one day, because many countries are planning on implementing similiar things) you should make sure your system is safe and up to date.

Sorry, my only recommendation is to setup a secure and up to date server environment.

Whatever ties your hands to this server enviroment should rethink this. There are always possibilities of security issues in software, even in the most recent versions. But using software versions that haven't been updated and are EOL for 4-5 years is basically asking for problems. Today robots are scanning the web continously, just checking for vulnerable software, it is only a matter of time until they find it.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Last edit: 1 week 4 days ago by holch.

Please Log in or Create an account to join the conversation.

More
1 week 3 days ago - 1 week 3 days ago #183223 by Ben_V
Hi,

with such environment your unique (but a good one) possibility is:

https://github.com/SondagesPro

Releases notes

Benoît

EM Variables => bit.ly/1TKQyNu | EM Roadmap => bit.ly/1UTrOB4
Last Releases => 2.6x.x goo.gl/ztWfIV | 2.06/2.6.x => bit.ly/1Qv44A1
Demo Surveys => goo.gl/HuR6Xe (already included in /docs/demosurveys)
Last edit: 1 week 3 days ago by Ben_V.

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!