How do you increase the max_input_vars?

More
4 months 1 week ago #172073 by jimdavies
jimdavies created the topic: How do you increase the max_input_vars?
I have a question with 621 options in a drop down but after 260 I get an error -
(Not all answer options were saved. This usually happens due to server limitations ( PHP setting max_input_vars) - please contact your system administrator.)

I'm on Version 2.50+ Build 160810

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #172074 by jelo
jelo replied the topic: How do you increase the max_input_vars?
Depending on your webserver/php setup you need to change the values in the php.ini.
There might be other ways (e.g. apache via htaccess) do modify the php variables. But that can be only answered by someone who setup the webserver/php combo.
php.net/manual/en/info.configuration.php#ini.max-input-vars

Are you a student conducting a survey? If yes, tell me why you use LimeSurvey?
www.limesurvey.org/forum/development/116...y-you-use-limesurvey

Please Log in or Create an account to join the conversation.

More
4 months 1 week ago #172077 by Joffm
Joffm replied the topic: How do you increase the max_input_vars?
Hi,

This usually happens due to server limitations ( PHP setting max_input_vars)


To make sure that in your case it is due to max_input_vars:

what is your setting of the max_input_vars?
Here is mine (a very standard hosting provider)


In version 2.73.1. I could add these 621 options in the drop down.


Joffm


Volunteers are not paid.
Not because they are worthless, but because they are priceless
Attachments:

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!