The table "{{asset_version}}" for active record class "AssetVersion" cannot be f

More
3 months 6 days ago - 3 months 6 days ago #169758 by imacat
imacat created the topic: The table "{{asset_version}}" for active record class "AssetVersi
Hi. I just upgrade my LimeSurvey from 3.9.0 to 3.10.0 today, and it shows this error:

The table "{{asset_version}}" for active record class "AssetVersion" cannot be found in the database.

I compared the existing database with a freshly-installed 3.10.0 database. It seems that a database table "lime_asset_version" is missing from the existing 3.9.0 database and is not automatically created with the 3.10.0 upgrade.

I tried several ways of installation and upgrade but failed. Is this a bug, or should I report this to somewhere?
Attachments:
Last Edit: 3 months 6 days ago by imacat.

Please Log in or Create an account to join the conversation.

More
3 months 6 days ago #169764 by tpartner
tpartner replied the topic: The table "{{asset_version}}" for active record class "AssetVersi
Yes, please file a bug report.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in or Create an account to join the conversation.

More
3 months 6 days ago - 3 months 6 days ago #169765 by DenisChenu
DenisChenu replied the topic: The table "{{asset_version}}" for active record class "AssetVersi
Can you have a look at your DBversion number at your global settings table ?

When update asset_version table must be created here : github.com/LimeSurvey/LimeSurvey/blob/85...edb_helper.php#L2215

And in the bug report : please set debug mode to 2

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last Edit: 3 months 6 days ago by DenisChenu.

Please Log in or Create an account to join the conversation.

More
3 months 6 days ago #169767 by LouisGac
LouisGac replied the topic: The table "{{asset_version}}" for active record class "AssetVersi
how did you updated?

Please Log in or Create an account to join the conversation.

More
3 months 6 days ago - 3 months 6 days ago #169771 by DenisChenu
DenisChenu replied the topic: The table "{{asset_version}}" for active record class "AssetVersi
OK found and fixed …
PR done with DB version at 249 but merged at 250 …

github.com/LimeSurvey/LimeSurvey/commit/...c8df8ad5323f92ba9d8c

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last Edit: 3 months 6 days ago by DenisChenu.

Please Log in or Create an account to join the conversation.

More
3 months 5 days ago #169820 by imacat
imacat replied the topic: The table "{{asset_version}}" for active record class "AssetVersi

DenisChenu wrote: OK found and fixed …
PR done with DB version at 249 but merged at 250 …

github.com/LimeSurvey/LimeSurvey/commit/...c8df8ad5323f92ba9d8c


Thank you. This works. And you people are fast. <3 ^_^

Please Log in or Create an account to join the conversation.

More
3 months 5 days ago #169821 by DenisChenu
DenisChenu replied the topic: The table "{{asset_version}}" for active record class "AssetVersi
Thanks to you to download and manually install :)

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!