problem to upload images or files

More
2 months 2 weeks ago #168467 by imoullet
imoullet created the topic: problem to upload images or files
Hello
I am not able to upload image to a survey using the "Browse uploaded resources" or also directly from the editor. Indeed I always get the error message : You don't have permissions to browse server.
I use Version 2.73.1+171220.

Everything works if I set disabled to false in the kcfinder config file but
I do not want to allow everyone to upload files to my server .


I precise I have no .htacess file and the permissions of my upload/surveys directory are OK

drwxrwxr-x. 17 apache apache 4096 May 7 16:40 surveys
Is there another solution ?

I can't right now upgrade to the 3.71 version

Thanks for your answer
This oroblem is quite urgent..

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #168469 by tpartner
tpartner replied the topic: problem to upload images or files
Please do not double post.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in or Create an account to join the conversation.

More
2 months 1 week ago #168604 by imoullet
imoullet replied the topic: problem to upload images or files
Sorry for the double post. But any idea to help me ?

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #170131 by Drewskie
Drewskie replied the topic: problem to upload images or files
Did you find a solution to the problem?

I have upgraded to 3.12.1 and the issue is still there.
I am running mine on Windows IIS server and the folder permission has everyone with full permission but still no luck.

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #170144 by imoullet
imoullet replied the topic: problem to upload images or files
No solution yet except to put the file by hand via ssh

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #170148 by holch
holch replied the topic: problem to upload images or files

I have upgraded to 3.12.1 and the issue is still there.
I am running mine on Windows IIS server and the folder permission has everyone with full permission but still no luck.


Did you file a bug report for this? A bug not reported is a bug not fixed. 2.73 branch wouldn't receive any fixes, because this branch is end of life. But now that you are on the latest branch and actually the latest release of this branch and this still persists, file a bug report. However, I actually believe that this is a server configuration problem.

imoullet, what is your server configuration? Linux or also Windows?

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago #170151 by imoullet
imoullet replied the topic: problem to upload images or files
Linux ( with or without selinux enabled , the problem persists)
Do not think it comes from a configuration issue since another appli running on the same server with the same user is able to write in the same directory ( I made the test)

Please Log in or Create an account to join the conversation.

More
1 month 2 days ago - 1 month 2 days ago #170156 by holch
holch replied the topic: problem to upload images or files
Then --> bug report

And include all information that could be interesting (e.g. the fact that you have another application with the same user and they can write to the same directory, etc.). This information is important to avoid that the developer will tell you "server configuration problem" and close the bug report. ;-)

But don't forget: For the latest branch/version of Limesurvey. There will be no bug fixes for 2.7x.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
Last Edit: 1 month 2 days ago by holch.

Please Log in or Create an account to join the conversation.

More
4 weeks 1 day ago #170327 by bnichols
bnichols replied the topic: problem to upload images or files
Hi Drewskie - did you check the specific user (IUSR) that IIS runs as has read/write access too? I've seen issues before but had to modify the following for exclusive rights:
"C:\inetpub\mysurveysite\tmp" needs IUSR to have full read/write access.
"C:\inetpub\mysurveysite\upload" needs IUSR to have full read/write access.
"C:\inetpub\mysurveysite\application\config" needs IUSR to have full read/write access.

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!