New install of 3.0.1 fails to create admin

More
1 year 8 months ago #162100 by soshaughnessey1
I am a current user of LimeSurvey Version 2.05+ Build 140116. My hosting ISP (GoDaddy) flagged a bunch of files as potentially containing malware. Rather than upgrade that version (and potentially not get rid of the malware), I decided to create a new implementation of 3.0.1 which I downloaded yesterday (12/30/17).

Some things must have changed with LimeSurvey since I did my original 1.x (which was eventually upgraded to 2.05)installation as my new installation isn't working.

My first apparent problem was an error message: "No input file specified". I searched and found the solution to change the config file to 'urlFormat' => 'get'. That allowed me to get the login window. I tried to login with "admin" "password" but it didn't take. I asked the software to send me a new password but it was never sent. I looked at the DB tables and there are no users in "lime_users". I checked my old installation and that same table has my data in it.

I have reinstalled the software 4 times now with exactly the same error in each case. I won't get into all of the hairy details of what I have tried but here is a quick list:
- I have tried to import the table from my old installation to this one and it still didn't work.
- I found a thread that gave an import of the admin user and that created me as a user but still did not allow me to log in. ( www.limesurvey.org/forum/installation-a-...reset-admin-password )
- I have tried to decipher the install code to see if I can find a bug but my PHP skills do not allow me to find anything that is blatantly wrong with the install process.

I have run out of ideas. Can anyone make a suggestion? I need to put out a survey soon and I am just going to use my old version of LimeSurvey but I would like to get that version off my server if it has been infected with malware.

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
1 year 8 months ago #162116 by jelo
Did you do a fresh installation with a new database? Or did you point the installation to the existing LimeSurvey database?
Since 3.0.1 is unstable (in terms of usage by real world users) it looks like a issue in the installer which might be dependent on your server setup. At least if it is a fresh installation without upgrade routines.
You should open a bug ticket and provide database version, php version etc. in the ticket.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #162117 by LouisGac
LS3 is already used by hundreds of users without any problems.

Front end has been deeply tested, it's perfectly stable. Backend could still have some bugs here and there, but nothing critical.

3.1.0 should be released very soon and used on our SAAS: but first we want to add few new features (Survey "Templates": typical surveys such as "customer satisfaction")

OP is clearly trying to update from a very old installation. So as always: please wait that we offer LS3 as an update in comfort Update, if you try to update manually, do it at your own risk.

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #162118 by soshaughnessey1
It was a perfectly clean install with a new DB and installing into a new directory. Nothing was upgraded. The only thing that was referenced from the previous install was that after I failed twice with brand new installs, I tried to export my admin row in the DB for users into the empty new install. The problem is obvious but I don't know how to work around it - the user DB table doesn't have an admin created. It is completely empty.

I don't know how to create a bug ticket - can you provide me the URL?

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #162119 by soshaughnessey1
Incorrect. I am not trying to do an update from the old installation. I have a brand new DB and a brand new upload to a different directory on my server.

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #162121 by jelo

soshaughnessey1 wrote: I don't know how to create a bug ticket - can you provide me the URL?

www.limesurvey.org/community/bug-tracker

There is already a different issue when doing a clean installation of 3.0.1
bugs.limesurvey.org/view.php?id=13106

But you GoDaddy hosting environment might be running older components too. You should check database and php version first. Perhaps LS 3 is not working cause php is too old or something else is missing.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #162128 by soshaughnessey1
I don't need to install the latest build. I couldn't find an older and more stable build out there. Is there a 2.x build that I can install instead? My number one goal is to get the older version that I am using now off my server.

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #162132 by jelo
You can find archived versions of LimeSurvey here:
www.limesurvey.org/stable-release/category/24-archived-releases

You can find versions via GITHUB here:
github.com/LimeSurvey/LimeSurvey/releases

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #162134 by soshaughnessey1
Is 2.0.6 the previous best release?

Please Log in or Create an account to join the conversation.

More
1 year 8 months ago #162138 by jelo
Depends on who you ask. The last version of the "old" development branch is Release 2.6.6-lts Build 171111.
The LS 3.X is the newest branch with a new template system.
The versions in-between have a different template system.

Depending on the need to run old survey with or without modified templates and workarounds the choice of the best version might differ.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!