Map-Funktion fehlerhaft

More
2 months 1 week ago #159349 by IUP_CG
IUP_CG created the topic: Map-Funktion fehlerhaft
Hallo,
ich möchte gern Fragen mit der Mapfunktion einbauen (Kurzer freier Text ). Allerdings habe ich da zwei Fehler/Probleme entdeckt:

1. Das Openstreet-Plugin hat eigentlich ein Suchfenster, wo ich dachte, man könnte dort Orte suchen. Das funktioniert aber nicht.
2. Die Einstellung der Kartenhöhe/-breite funktioniert nicht richtig. Ich habe ein sehr lang gestrecktes Gebiet und möchte dementsprechend eine größere Höhe als Breite haben. Wenn ich dort die Pixelwerte angebe ändert sich baer nichts.

Sind das bekannte Fehler oder ist das nur bei mir so?

Gruß,
Cedric

Please Log in to join the conversation.

More
2 months 1 week ago #159351 by Joffm
Joffm replied the topic: Map-Funktion fehlerhaft
Hallo, Cedric,

1. Das Openstreet-Plugin hat eigentlich ein Suchfenster, wo ich dachte, man könnte dort Orte suchen. Das funktioniert aber nicht.

Soll das heißen "Eigentlich hat das Plugin ein Suchfenster", aber es ist bei Dir nicht da?
Oder funktioniert das Suchfenster nicht?
Also bei mir LS Version Version 2.67.3+170728, default-Template funktioniert dies reibungslos (siehe screenshots)

2. Die Einstellung der Kartenhöhe/-breite funktioniert nicht richtig. Ich habe ein sehr lang gestrecktes Gebiet und möchte dementsprechend eine größere Höhe als Breite haben. Wenn ich dort die Pixelwerte angebe ändert sich aber nichts

.
Also bei mir ändert sich die Höhe. (siehe screenshot mit einer Höhe von 50px)
Aber wir haben den Fall, dass die Kartenhöhe zwar geändert wird, die Breite aber immer 100% des Eingabebereiches einnimmt.

Dies kannst Du aber ändern, indem Du in den Fragetext (natürlich im Quellcode-Modus) ein bisschen css zufügst.
Wie z.B.
<style type="text/css">
.leaflet-container {
  width:50% !important;
  margin-left:25% !important;
}
</style>
Ist eigentlich selbsterklärend. Die Breite wird auf 50% der Fensterbreite gesetzt, und dr linke Rand auf 25%, damit es schön in derr Mitte ist.
Einfach etwas damit herumspielen.

Viel Erfolg
Joffm
Attachments:
The following user(s) said Thank You: IUP_CG

Please Log in to join the conversation.

More
2 months 6 days ago #159391 by IUP_CG
IUP_CG replied the topic: Map-Funktion fehlerhaft
Hallo Joffm,
danke für die Hinweise! Deinen Tipp probiere ich gleich aus. Also bei mir ist das Suchfenster da, aber wenn ich da was eingebe passiert nichts. Liegt es daran, dass ich im Vorschaumodus bin?
Ich würde ja auch sehr gern mal nen Test machen, bei der ich die Umfrage beantworte, die Ergebnisse gespeichert werden und ich diese runterladen/ansehen kann, ohne dass ich die Umfrage gleich freischalte.
Geht sowas?

Please Log in to join the conversation.

More
2 months 6 days ago #159398 by IUP_CG
IUP_CG replied the topic: Map-Funktion fehlerhaft
Also der Tipp funktioniert. Ich weiß jetzt, warum das Such-Plugin nicht funktioniert. Es hat irgendwas mit Sicherheitseinstellungen zu tun. Bei meinem Arbeitsrechner habe ich das jetzt hinbekommen, wenn ich beim Internet Explorer bei der Popup-Meldung angebe, dass alle und nicht nur sichere Inhalte angezeigt werden sollen. Bei Firefox muss es ja auch so eine Einstellung geben, die das zum Laufen bringt. Nutzt dieses Suchplugin irgendein spezielles Programm wie Flash oder so?
Ein neues Problem ist aufgetaucht. Ich habe eingestellt, dass sich die Kartenfragen erst einblenden, wenn eine bestimmte Filterfrage davor beantwortet ist. Dann wird aber an meinem Arbeitsrechner weder bei Firefox noch beim Internet Explorer die Karte richtig aufgebaut (es wird nur ein Teil angezeigt). Am Tablet tritt das Problem nicht auf. Wenn ich die Umfrage online stelle und die Leute haben ähnliche Probleme wäre das sehr ungünstig.

Please Log in to join the conversation.

More
2 months 6 days ago #159419 by Joffm
Joffm replied the topic: Map-Funktion fehlerhaft
1. Ja, wenn Du hier unter "Projekt" auf "Demo" gehst, hast Du doch alles, was Du brauchst.
Das ist genau die Umgebung, um Sachen auszuprobieren.


2. Ist die "Filterfrage" auf derselben Seite oder auf einer anderen?
Soll heißen "Gruppe für Gruppe" oder "Frage für Frage"?

Joffm
The following user(s) said Thank You: IUP_CG

Please Log in to join the conversation.

More
2 months 5 days ago #159437 by IUP_CG
IUP_CG replied the topic: Map-Funktion fehlerhaft
zu 1: meinst du ich kann mit dem Demo-Zugang meine Umfrage so testen wie ich beschrieben habe?
zu 2: Gruppe für Gruppe ist eingestellt. bei Frage für Frage geht es. Aber würde lieber Gruppe für Gruppe einstellen.

Please Log in to join the conversation.

More
2 months 5 days ago #159479 by Joffm
Joffm replied the topic: Map-Funktion fehlerhaft
Dann solltest Du uns mal die entscheidenden Fragen als sample (*.lss) rüberschieben.

Please Log in to join the conversation.

More
2 months 4 days ago #159495 by IUP_CG
IUP_CG replied the topic: Map-Funktion fehlerhaft
Die Probleme mit der Mapfunktion sind gelöst. Das mit dem Suchfeld war ein Bug, der inzwischen behoben wurde (Vielen Dank). Das sich die Karte nicht richtig aufbaut bei der Einstellung "Gruppe für Gruppe" mit den Filterfragen davor, kann man schnell korrigieren: kurz zoomen (nicht Karte, sondern Browser) daraufhin baut sich das von allein richtig auf. Schöner wäre natürlich wenn es sofort klappt, aber notfalls muss man einen Hinweis unten angeben.
Übrigens: Den Fixen Hinweis der immer unter der Karte steht ist ein bisschen unglücklich. Das man auch Koordinaten eingeben kann ist schön, aber welcher Ottonormalverbraucher kann das? Besser wäre ein Hinweis darauf, dass man auch Orte, Städte, Straßen etc. mit dem Feld suchen kann.

Please Log in to join the conversation.

More
2 months 4 days ago #159515 by Joffm
Joffm replied the topic: Map-Funktion fehlerhaft
Naja, den Text unten kannst Du ja ausblenden mit "Hinweis verstecken".
Für einen geänderten Text bleibt wohl nichts anderes als die Übersetzung zu manipulieren.

Bis dann
Joffm

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!