Test E-Mail-Versand

More
3 years 9 months ago #133720 by Volker62
Test E-Mail-Versand was created by Volker62
Sorry, war zunächst im falschen Forum. Daher hier noch einmal mein Anliegen:

Hallo Fachleute,

seit einigen Wochen teste ich jetzt LimeSurvey und finde, dass es ein ganz tolles Programm ist. Da ich es in Zukunft bei mehreren Projekten einsetzen will, wollte ich auch den Versand von E-Mails zum Testen eines Fragebogens ausprobieren. Ich habe 4 Testadressen erzeugt, sie importiert, Zugangsschlüssel vergeben und die Einladungen auch versendet. Doch keine der Adressen erhielt eine Benachrichtigung. Der Versand erfolgte ohne Fehlermeldung und in der Zusammenfassung wird auch ausgewiesen: "Anzahl versandte Einladungen 4".

Es handelt sich bei dem Programm um die Windows PC-Version LimeSurvey Version 2.50+ Build 160317 on xampp. Ich benutze Firefox 45.0.01 unter Windows 7, Home Edition.

Kann ich diese Funktion eventuell nur testen, wenn ich mein Projekt beim einem Dienstleister hoste? Falls ja, Welche Anforderungen werden an einen derartigen Anbieter gestellt. Ich habe z.B. eine Homepage bei einem Unternehmen.

Ich bin kein Technikspezialist und schon froh, dass ich Limesurvey zum Laufen gebracht habe. Vielen Dank für eure Mühe und

viele Grüße

Volker

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
3 years 9 months ago #133721 by jelo
Replied by jelo on topic Test E-Mail-Versand
Der Versand ist abhängig von den Emailversand-Einstellungen, die Du in Limesurvey gewählt hast.
Falls Du via SMTP mit Zugangsdaten verschickst, werden die E-Mails sicherlich auch über das lokal installierte Limesurvey auf Deinem Rechner versendet werden. Problem dürfte eher sein, dass Du Deinen Rechner ja nicht als Webserver dauerhaft für Dritte im Internet verfügbar hast.
Die Einladungslinks dürften somit nicht für Dritte außerhalb Deines lokalen Netzwerkes erreichbar sein.

Daher würde die Nutzung eines Dienstes wie LimeSurvey Professional (previously LimeService).com für Dich sicherlich mehr Sinn machen.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users
The following user(s) said Thank You: Volker62

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago - 3 years 9 months ago #133725 by Mazi
Replied by Mazi on topic Test E-Mail-Versand
[Post im falschen Forum gelöscht]
Also wenn die Email ohne Fehlermeldung herausgingen und dein lokaler Server korrekt konfiguriert ist, sollte sie zunindest bis zum Mailserver gelangt sein. Der kann den Weiterversand aber immer noch blocken, es als Spam einstufen, verspätet ausliefern, ...

In der Regel würde ich erst einmal im Spamordner nachschauen.

Schaue auch mal auf die Tips hier www.limesurvey-consulting.com/how-to-pre...ing-treated-as-spam/

Best regards/Beste Grüße,
Dr. Marcel Minke
Need Help? We offer professional Limesurvey support
Contact: marcel.minke(at)survey-consulting.com
Want to use your survey offline -> www.offlinesurveys.com
Last edit: 3 years 9 months ago by Mazi.
The following user(s) said Thank You: Volker62

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #133750 by holch
Replied by holch on topic Test E-Mail-Versand
Ich vermute mal, dass XAMPP überhaupt nicht für den Versand von Emails konfiguriert ist, wenn du über die PHP Methode verschickst.

I'm not a LimeSurvey GmbH member. I answer at the LimeSurvey forum in my spare time. No support via private message.
Some helpful links: Manual (EN) | Question Types | Workarounds
The following user(s) said Thank You: Volker62

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #133753 by Volker62
Replied by Volker62 on topic Test E-Mail-Versand
Hallo Jelo,
vielen Dank für Deine schnelle Antwort. Daraus schließe ich, dass es grundsätzlich auch mit der xampp-Version möglich ist, den Versand zu testen.
Ich hatte es zunächst mit der Grundeinstellung (also php) versucht und bekam keine Fehlermeldung - aber auch keine Zustellung. Danach nach dem Hinweis vom Mazi via SMTP. Dabei erhielt ich dann die Fehlermeldung: "Verbindung zu SMTP Server fehlgeschlagen" und den Hinweis zu einem php-Forum, was mir aber nicht weiterhalf. Ich weiß nicht, was ich in der Konfiguration von Limesurvey noch ändern muss. Ich habe meinen Host- und Benutzername sowie mein Passwort dazu angegeben. Leider erfolglos. Woran könnte es sonst noch liegen?
Nein, ich will den Rechner nicht dauerhaft für Dritte zur Verfügung stellen. Bei echten Projekten werde ich mir sicherlich auch einen professionelle Dienstleister auswählen.

Gruß Volker

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #133754 by Volker62
Replied by Volker62 on topic Test E-Mail-Versand
Hallo Mazi,
vielen Dank für Deine schnelle Antwort. Wie muss denn mein "lokaler Server korrekt konfiguriert" sein? Bei dem Versandversuch mit SMTP habe ich meinen Host- und Benutzername sowie das Passwort eingegeben. Dort erhielt ich dann aber für alle getesteten Adressen die Fehlermeldung ("Verbindung zu SMTP Server fehlgeschlagen", was ja darauf hindeutet, dass sie erst gar nicht herausgegangen sind).
In den jeweiligen Spamordner kam ebenfalls nichts an.
Die E-Mail-Tipps bin ich noch nicht alle durchgegangn. Ich glaube aber eher, dass es an der Konfiguration liegt.

Viel Grüße
Volker

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #133755 by Volker62
Replied by Volker62 on topic Test E-Mail-Versand
Hallo Holch,
vielen Dank für Deine Antwort. Ich bin völliger Neuling was Webserver, php, MySql und xampp betrifft. Wie muss ich denn XAMPP bzw. php konfigurieren? Ich weiß noch nicht einmal wo ich da was eintragen muss.
Vielen Dank und viele Grüße
Volker

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #133759 by jelo
Replied by jelo on topic Test E-Mail-Versand

Volker62 wrote: Ich habe meinen Host- und Benutzername sowie mein Passwort dazu angegeben. Leider erfolglos. Woran könnte es sonst noch liegen?

Ich habe in meinem Post ja SMTP als Methode erwähnt.
Die Daten für SMTP sind die gleichen, wie in einem E-Mailprogramm. Du verwendest über ein E-Mailpostfach. Wie der SMTP-Server angesprochen wird, hängt von Deinem E-Mailprovider ab.

Volker62 wrote: Nein, ich will den Rechner nicht dauerhaft für Dritte zur Verfügung stellen. Bei echten Projekten werde ich mir sicherlich auch einen professionelle Dienstleister auswählen.

Es wird auch nicht zeitweise gehen, wenn Du wie 95% der Internetnutzer hinter einem NAT-Router sitzt.
Dann werden durch das Versenden von E-Mails von Deiner Installation aus ja auch keine Nutzer den Weg zu Deinem Rechner finden.

Zum Testen von Limesurvey kann das so alles passen.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #133922 by Volker62
Replied by Volker62 on topic Test E-Mail-Versand
Hallo Jelo,
ich stelle unter Globale Einstellungen - E-Mail-Einstellungen bei E-Mail-Methode SMTP ein, gebe meinen SMTP-Server entsprechend an, meine E-Mail-Adresse und das zugehörige Passwort, außerdem stelle ich den Debugmodus auf "Fehler". Das ganze speichere ich ab.
Bei weiteren Versuchen ist mir aufgefallen, dass nicht mein 9-stelliges E-Mail-Passwort verwendet wird sondern irgendetwas anderes mit 12 Stellen - was genau, kann ich aber nicht sehen, da ja nur Punkte angezeigt werde. Und in der Debugmeldung steht dann u.a. "Password command failed: 535". Wieso wird offensichtlich bei Abspeichern ein anderes Passwort eingesetzt? Ich habe es sowohl mit "Speichern" als auch mit "Speichern und schließen" versucht.

Viele Grüße
Volker

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #133932 by jelo
Replied by jelo on topic Test E-Mail-Versand
Da bin ich überfragt. Ich würde jetzt spontan auf einen Fehler in LS 2.5 tippen. Ich selbst nutze LS 2.5 nicht, sondern bin noch auf LS 2.06LTS.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users

Please Log in or Create an account to join the conversation.

More
3 years 9 months ago #133935 by Volker62
Replied by Volker62 on topic Test E-Mail-Versand
Unter „admin“ – „Bearbeiten Sie Ihr Profil“ steht unter „Kennwort“ seltsamerweise auch ein 12-stelliger Eintrag. Wenn ich mich aber bei LimeSurvey einlogge, erscheint unter „Kennwort“ ein 9-stelliger Eintrag. Und wenn ich dort das Kennwort eingebe, das ich mir notiert habe, kann ich mich problemlos einloggen. Es scheint also irgendwie einen Zusammenhang zu geben. Wie kann ich das lösen?
Ist diese anscheinend stabile Version LS 2.06LTS auch als standalone auf einem Windows-Rechner nutzbar?

Please Log in or Create an account to join the conversation.

More
2 months 2 weeks ago #190723 by leofuehringer
Replied by leofuehringer on topic Test E-Mail-Versand
Das mit den 12 Stellen hat nichts zu sagen. Das sind nur Platzhalter. Aus Sicherheitsgründen soll keiner wissen, wie lang dein Passwort ist!

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!