Random question order only works on group preview

More
3 years 6 months ago - 3 years 6 months ago #107003 by blacknail
blacknail created the topic: Random question order only works on group preview
Hello all,

I have a study where I want a set of 22 questions to be randomly presented to the respondents. Since they are all in the same question group, I've assigned the same randomization group name to each question (more precisely in each question's advanced settings respective option). The thing is, when I preview the question group, the questions appear as I want, i. e., randomly ordered. However, if I test the survey (activated or not, the result is the same), the questions appear in their natural order. I've tried to clear Chrome's cache to no success. I searched but couldn't find a similar problem out there in the forums, did anyone know what might be happening here?

By the way, I doubt this helps but they're array questions. And I'm using LS version 2.00+ Build 121017.

All the best,
João

P.S.: I even assigned the same randomization group name to the group where these questions are, also with no success, although that doesn't surprises me, since I think this is only valuable for randomizing groups, isn't it?
Last Edit: 3 years 6 months ago by blacknail. Reason: Missing a word in the title

Please Log in to join the conversation.

More
3 years 6 months ago - 3 years 6 months ago #107008 by blacknail
blacknail replied the topic: Random question order only works on group preview
The same is equal to follow the procedure pointed in this thread:

http://www.limesurvey.org/en/community-services/forums/design-issues/94822-how-to-random-the-question-display-seq

Can someone help me?
Last Edit: 3 years 6 months ago by blacknail.

Please Log in to join the conversation.

More
3 years 6 months ago #107032 by DenisChenu
DenisChenu replied the topic: Random question order only works on group preview
Hi,

blacknail wrote: And I'm using LS version 2.00+ Build 121017.


We fix a lot of bug in randomisation in last version, please test with the mast version (2.05).

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
The following user(s) said Thank You: blacknail

Please Log in to join the conversation.

More
3 years 6 months ago #107062 by blacknail
blacknail replied the topic: Random question order only works on group preview
Hi Denis, thanks for your answer.

Unfortunately, I don't know if an upgrade is a viable solution, since I'm not the network administrator around here, I'm just another user. Of course I will contact the system administrator team and ask for an upgrade to the latest version, I hope it can happen soon.

The remaining question is: do you think there is a workaround for this (other than an upgrade, of course)?

All the best,
João

Please Log in to join the conversation.

More
3 years 6 months ago #107063 by DenisChenu
DenisChenu replied the topic: Random question order only works on group preview
Hi,

To validate if it's work with last version, you can test in 2.05 Demo version : www.limesurvey.org/en/Demo

For workaround : if it's the same page, maybe you can move question wrapper according to some random value.

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
The following user(s) said Thank You: blacknail

Please Log in to join the conversation.

More
3 years 6 months ago #107070 by blacknail
blacknail replied the topic: Random question order only works on group preview
Not only it, worked with the Demo version, I got Tech Support department to install it, is apparently working smooth & painless, many many thanks! :]

Best regards,
João

P.S.: Don't know if it helps, but before upgrading to 2.05 I've tried to randomize groups (created 2 groups with 1 question each), also with no success. Your suggestion wouldn't work here because I have one question per page.

Please Log in to join the conversation.

More
3 years 6 months ago - 3 years 6 months ago #107073 by DenisChenu
DenisChenu replied the topic: Random question order only works on group preview

blacknail wrote: P.S.: Don't know if it helps, but before upgrading to 2.05 I've tried to randomize groups (created 2 groups with 1 question each), also with no success. Your suggestion wouldn't work here because I have one question per page.

Before some fix, question in different group are never shown ...
random_group for 2 question in 2 different group are completely broken.

But now, it work.

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
Last Edit: 3 years 6 months ago by DenisChenu.
The following user(s) said Thank You: blacknail

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now