Help with Exclusive Option

More
3 years 5 months ago #109442 by rduraoc
rduraoc created the topic: Help with Exclusive Option
HI all,

New user to the forum, but I've been using Limesurvey for some time now. I'm having an issue with the "Exclusive option" in multiple choice questions: the other options are not excluded if I check the exclusive one. I know this might be a bug, but maybe I'm just missing something. More data:

- The other options are not excluded automatically when I am answering, but if I continue to the next question and then come back, all other options disappear, and only the exclusive is shown;
- I have used "Exclusive option" before with success - but in previous versions of Limesurvey
- I am using version 2.05+ - and this might be were the problem is
- I am using a Mac, and tested with Chrome (Version 35.0.1916.114) and Safari (Version 6.1.4 (7537.76.4)). In Windows the result is the same.

Is this a bug, or am I missing something?

Thanks!

Please Log in to join the conversation.

More
3 years 5 months ago #109476 by tpartner
tpartner replied the topic: Help with Exclusive Option
Have you tested with a shipped template?

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
3 years 5 months ago #109504 by rduraoc
rduraoc replied the topic: Help with Exclusive Option
I have made some changes to the template, but it is the same I used in previous surveys - and then it worked perfectly. That is why I am thinking this might be a 2.05+ bug...

Please Log in to join the conversation.

More
3 years 5 months ago #109506 by tpartner
tpartner replied the topic: Help with Exclusive Option

but it is the same I used in previous surveys - and then it worked perfectly

2.05 uses newer versions of jQuery and jQuery UI which may not be compatible with JavaScript written for 2.0 (some functions/methods have been deprecated or changed). I would look for JavaScript errors in your template.


.

Cheers,
Tony Partner
Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
3 years 5 months ago #109507 by rduraoc
rduraoc replied the topic: Help with Exclusive Option
The changes I made to the template were only graphic - add a logo, change some colors - but I've just tried with a default template and it is working now. Thanks!

Please Log in to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!