Ranking: decrease lenght of box which displays items to be ranked

More
2 years 11 months ago #107983 by Bart01
I created a Question Type Ranking.
on this question type I also use an array filter.
The length of the box in which the to be chosen items are displayed is a fixed length, not influenced by the array filter, but based upon the (maximum) number of possible items in the question.
This displays very ugly, especially if there is a large number of empty items which are suppressed by the use of the array filter.
Any tips on how to resolve this? Workaround?

Please Log in to join the conversation.

More
2 years 11 months ago #108002 by tpartner
Add this to the end of template.css, replacing "QQ" with your question ID .

#questionQQ .dragDropChoiceList {
	min-height: 0 !important;
}

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
2 years 11 months ago #108004 by Bart01
Hi Tony,

thx for your respons.

Alas not successful, still too large box around ranking items.
I attached a screenprint, which might shed some more light on this.

Question has theoretically 108 options, so there are 108 subquestions.
But this numbers is decreased using an array filter. In the attached screen print 9 choices, or 9 items to be ranked.

The display box surrounding however calculates without the array filter, so the lenght is based upon 108 options, in stead of the 9.

The screenprint only shows 1 screen, but to reach the end of the question, i have to scroll down much further.
Attachments:

Please Log in to join the conversation.

More
2 years 11 months ago #108005 by tpartner
That should work if you use the correct ID. Can you activate a test survey for me to see?

Cheers,
Tony Partner

Solutions, code and workarounds presented in these forums are given without any warranty, implied or otherwise.

Please Log in to join the conversation.

More
2 years 11 months ago #108010 by Bart01
tony,

pls find attached a simple example,
thx,

Bart
Attachments:

Please Log in to join the conversation.

More
2 years 11 months ago #108011 by Bart01
tony,

seems to work fine, now.
I changed to another survey, in order to make the example (from the former post).
I moved back to my original survey, and now it is handling it all fine.
Apparently, I needed to do some sort of refresh......


Anyway, it is working now.
thx again for your support,

Please Log in to join the conversation.