Japanese language is not displaying correctly when png is generated

More
3 years 9 months ago #100991 by skye
skye created the topic: Japanese language is not displaying correctly when png is generated
I have a problem when I try to do responses and statistics in japanese then view the statistics using pdf/html. The PNG that was generated does not have correct japanese language. I can see squares instead of japanese. Please help.

Is this a bug?

Thanks.
Attachments:

Please Log in to join the conversation.

More
3 years 9 months ago #100992 by c_schmitz
c_schmitz replied the topic: Japanese language is not displaying correctly when png is generated
Assuming that you are using the latest 2.0 version:

For package size reasons the migmix-1p-regular.ttf font to show Japanese characters in the statistics graphs is not included with LimeSurvey.

Please download it from mix-mplus-ipa.sourceforge.jp/migmix/ ,
unzip and put the migmix-1p-regular.ttf file into the /fonts directory of your LimeSurvey installation.

Best regards

Carsten Schmitz
LimeSurvey project leader
The following user(s) said Thank You: skye

Please Log in to join the conversation.

More
3 years 9 months ago #101000 by DenisChenu
DenisChenu replied the topic: Japanese language is not displaying correctly when png is generated
Yes,

And it's explain here :
github.com/LimeSurvey/LimeSurvey/blob/ma...-%20Japanese.ttf.txt

For information (mine), PDF use cid0jp font from tcpdf : did PDF are OK ?

And another think : to Carsten : i think we put an alert if there are font file in text but no fonts : maybe this a bug (little).

Denis

Assistance on LimeSurvey forum and LimeSurvey core development are on my free time.
I'm not a LimeSurvey GmbH member, professional service on demand (or search sondages pro).
An error happen ? Before make a new topic : remind the Debug mode .
The following user(s) said Thank You: skye

Please Log in to join the conversation.

More
3 years 9 months ago #101011 by skye
skye replied the topic: Japanese language is not displaying correctly when png is generated
thank you for your answers. I tried it and it worked.

Please Log in to join the conversation.

Did you already participate in our customer survey?

Don't miss your chance for great prices.

Please click here to participate:

Start now

Start now!

Just create your account and start using Limesurvey today.

Register now