Mod_Security error on Text Display question

More
3 months 3 weeks ago #185070 by cberghoff
Hi everyone,

When saving a text display item, we are receiving a webpage with the following message...

Not Acceptable!

An appropriate representation of the requested resource could not be found on this server. This error was generated by Mod_Security.

...

This is a new problem for us. I was running 3.15.something and we started getting the error (was running fine at some point). I just updated to 3.17.4+190529 and the error is persisting.

Any help how to resolve this problem is appreciated, thank you!

Please Log in or Create an account to join the conversation.

LimeSurvey Partners
More
3 months 3 weeks ago #185086 by jelo
You need to adapt the modsecurity configuration (e.g. remove rules or deactivate rules for certain paths or URLS). You will need to check the mod security log files to see what rule is triggered.

The meaning of the word "stable" for users
www.limesurvey.org/forum/development/117...ord-stable-for-users
The following user(s) said Thank You: DenisChenu

Please Log in or Create an account to join the conversation.

More
3 months 3 weeks ago #185142 by cberghoff
Issue resolved:

To let everyone know, I use HostGator for my hosting. Apparently, they changed something and I don't have access to that log file. A chat with tech support and clearing my cache resolved the issue. The technician said they whitelisted the path that was causing the problem, but didn't give me specifics.

Hope this helps someone in the future!

Please Log in or Create an account to join the conversation.

Start now!

Just create your account and start using Limesurvey today.

Register now
Join our Newsletter!